summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-08-20 13:45:49 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-08-20 14:10:49 +0200
commit979611d4ddb3e4fcd23b53ae05836750939dfdec (patch)
treef5ded4c1dcb53a6b3c52746c7c37bb2e394aa285 /gnu/packages/maths.scm
parentf91097c509e6f1327715f5dc4e44f914e6bb42ef (diff)
gnu: hdf4: Fix compiling with gfortran 10.
* gnu/packages/maths.scm (hdf4)[arguments]: Add 'allow-argument-mismatch' flag for gfortran in 'configure-flags'. Fix regexp in 'patch-settings' phase.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index a7931e6eeb..82ca9caff3 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1083,6 +1083,8 @@ computations.")
(arguments
`(#:parallel-tests? #f
#:configure-flags (list "--enable-shared"
+ "FCFLAGS=-fallow-argument-mismatch"
+ "FFLAGS=-fallow-argument-mismatch"
(string-append "CPPFLAGS=-I"
(assoc-ref %build-inputs "libtirpc")
"/include/tirpc"))
@@ -1116,7 +1118,7 @@ computations.")
;; .so-files. We truncate the hashes to avoid
;; unnecessary store references to those compilers:
(substitute* "libhdf4.settings"
- (("(/gnu/store/)([a-Z0-9]*)" all prefix hash)
+ (("(/gnu/store/)([0-9A-Za-z]*)" all prefix hash)
(string-append prefix (string-take hash 10) "...")))
#t))
(add-after 'install 'provide-absolute-libjpeg-reference