summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-07-25 10:29:03 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-07-25 10:29:07 +0300
commitb8894e8065643fb05fbf0cea4b6ee98658dd0fdf (patch)
tree2375d89d583e4dd7050b8b124205f807e829b323 /gnu/packages/maths.scm
parent7bef3be1d318beebaf48ac6daa3140205ba18e98 (diff)
gnu: openblas: Use dynamic arch support for aarch64-linux.
* gnu/packages/maths.scm (openblas)[arguments]: Adjust make-flags to build multiple architecture optimized versions for aarch64-linux.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 292b2e41d6..e7f82341e8 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3877,7 +3877,8 @@ parts of it.")
(string-prefix? "i686" system))
'("DYNAMIC_ARCH=1"))
;; On some of these architectures the CPU can't be detected.
- ((string-prefix? "powerpc64le" system)
+ ((or (string-prefix? "powerpc64le" system)
+ (string-prefix? "aarch64" system))
'("DYNAMIC_ARCH=1"
"TARGET=GENERIC"))
;; On MIPS we force the "SICORTEX" TARGET, as for the other
@@ -3885,9 +3886,6 @@ parts of it.")
;; for Loongson cores are used.
((string-prefix? "mips" system)
'("TARGET=SICORTEX"))
- ;; On aarch64 force the generic 'armv8-a' target
- ((string-prefix? "aarch64" system)
- '("TARGET=ARMV8"))
;; Failed to detect CPU.
((string-prefix? "armhf" system)
'("TARGET=ARMV7"))