summaryrefslogtreecommitdiff
path: root/gnu/packages/matrix.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2023-09-11 16:24:42 +0800
committerMarius Bakke <marius@gnu.org>2023-09-22 01:29:20 +0800
commit36821b23b7f5320a6d3926afcff22d2bfe3ed0eb (patch)
tree8e78426a743027de936ce9cade7f5f52cb76081b /gnu/packages/matrix.scm
parenta0aff95db93f2730b57fe3411fdf2e1d8eb194ff (diff)
gnu: python-cachetools: Update to 5.3.1.
* gnu/packages/python-xyz.scm (python-cachetools): Update to 5.3.1. * gnu/packages/matrix.scm (python-matrix-nio)[arguments]: Add phase to loosen cachetools requirement.
Diffstat (limited to 'gnu/packages/matrix.scm')
-rw-r--r--gnu/packages/matrix.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/matrix.scm b/gnu/packages/matrix.scm
index 6107dfc979..32ae62fcb4 100644
--- a/gnu/packages/matrix.scm
+++ b/gnu/packages/matrix.scm
@@ -171,6 +171,13 @@ homeserver and generally help bootstrap the ecosystem.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "pyproject.toml"
+ ;; Remove upper bounds of cachetool pin.
+ (("cachetools (.*version = )\"\\^4" _ match)
+ (string-append "cachetools " match
+ "\">=4")))))
(add-before 'check 'install-tests
(lambda* (#:key inputs outputs #:allow-other-keys)
(copy-recursively (string-append