summaryrefslogtreecommitdiff
path: root/gnu/packages/medical.scm
diff options
context:
space:
mode:
authorMarco Rimoldi <rimarko@libero.it>2024-01-25 22:31:08 +0100
committerLudovic Courtès <ludo@gnu.org>2024-02-10 22:54:05 +0100
commit11d5b505e5e0f6bccd804d407cc609b421962073 (patch)
tree0470c18bc2039456f333a80e040ed4358d96984c /gnu/packages/medical.scm
parent9474e64b098d52159ccec62969e6dceb924d5d5d (diff)
gnu: openmolar-1: Update to release 1.1.6-g81838c8 and partial runtime fix.
Fixes <https://issues.guix.gnu.org/29365>. WebKit was removed from Qt5 in favor of WebEngine; upstream addressed this in their last stable release, in 2018. The package still fails at runtime: this commit lays the ground for further fixes. * gnu/packages/medical.scm (openmolar-1): Update to release 1.1.6-g81838c8. [arguments]: Extend 'patch-/usr phase to source file localsettings.py. [inputs]: Add python-pyqtwebengine. [propagated-inputs]: Add qtwebengine-5. Change-Id: Ia4e4c052397201c26834dec2358ca5c20beb581d Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/medical.scm')
-rw-r--r--gnu/packages/medical.scm54
1 files changed, 28 insertions, 26 deletions
diff --git a/gnu/packages/medical.scm b/gnu/packages/medical.scm
index 33877083e2..15bd870f83 100644
--- a/gnu/packages/medical.scm
+++ b/gnu/packages/medical.scm
@@ -83,32 +83,34 @@ Health Federation.")
(define-public openmolar-1
(package
- (name "openmolar")
- (version "1.0.15-gd81f9e5")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://static.openmolar.com/om1/releases/openmolar-"
- version ".tar.gz"))
- (sha256
- (base32
- "1cfdzfbi6wslw7k0dc6ad6xrgs75iwsl91cg73w4myswaqqkfk3z"))))
- (build-system python-build-system)
- (arguments
- `(#:use-setuptools? #f
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-/usr
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "setup.py"
- (("/usr") (assoc-ref outputs "out")))
- #t)))))
- (inputs
- (list python-pyqt+qscintilla python-mysqlclient qscintilla))
- (home-page "https://openmolar.com/om1")
- (synopsis "Dental practice management software")
- (description "Openmolar is a dental practice management suite. Its
+ (name "openmolar")
+ (version "1.1.6-g81838c85")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://static.openmolar.com/om1/releases/openmolar-" version
+ ".tar.gz"))
+ (sha256
+ (base32 "09vrfqn511vswnj2q9m7srlwdgz066qvqpmja6sg1yl1ibh3cbpr"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:use-setuptools? #f
+ #:phases (modify-phases %standard-phases
+ (add-after 'unpack 'patch-/usr
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* '("setup.py"
+ "src/openmolar/settings/localsettings.py")
+ (("/usr")
+ (assoc-ref outputs "out"))) #t)))))
+ (inputs (list python-pyqtwebengine python-pyqt+qscintilla
+ python-mysqlclient qscintilla))
+ (propagated-inputs (list qtwebengine-5))
+ (home-page "https://openmolar.com/om1")
+ (synopsis "Dental practice management software")
+ (description
+ "Openmolar is a dental practice management suite. Its
functionality includes appointments, patient records, treatment planning,
billing etc. It is a full featured, reliable and thoroughly tested
application and has been translated into many languages.")
- (license gpl3+)))
+ (license gpl3+)))