summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-07-24 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-07-24 02:00:00 +0200
commitf8b7320ab22a9df2450b338d5755ae4ae1e281c6 (patch)
treeb0b85d82289f38a9105e59eb5e027ed8fc597c3b /gnu/packages/messaging.scm
parentd62b180ffd403df551329a653e526a8cc660b2d1 (diff)
gnu: freetalk: Modernise arguments' style.
* gnu/packages/messaging.scm (freetalk)[arguments]: Use a G-expression. Use SEARCH-INPUT-FILE to find representative binaries instead of relying on package names, and 'suffix rather than 'prefix their location to PATH.
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm30
1 files changed, 16 insertions, 14 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 1581434ae8..eee082ed8e 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2091,20 +2091,22 @@ support, and more.")
"105mw7pg2mcp85r82cs4rv77nwvbw8025047364jzbq6lwllynxv"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- ;; For 'system' commands in Scheme code.
- (add-after 'install 'wrap-program
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bash (assoc-ref inputs "bash"))
- (coreutils (assoc-ref inputs "coreutils"))
- (less (assoc-ref inputs "less")))
- (wrap-program (string-append out "/bin/freetalk")
- `("PATH" ":" prefix
- ,(map (lambda (dir)
- (string-append dir "/bin"))
- (list bash coreutils less))))))))))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'wrap-program
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (wrap-program (string-append out "/bin/freetalk")
+ `("PATH" ":" suffix
+ ,(map (lambda (command)
+ (dirname
+ (search-input-file
+ inputs (string-append "bin/" command))))
+ ;; This list is not exhaustive: we assume that,
+ ;; e.g., cat is packaged with other coreutils.
+ (list "bash" ; src/{commands,util}.c et al
+ "cat" ; extensions/first-time-run.sh
+ "less")))))))))) ; extensions/history.scm.
(native-inputs
(list autoconf automake pkg-config texinfo))
(inputs