summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-12 00:13:46 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-13 02:04:58 -0400
commite1ae27e712f54283df614e709c68bc8f2c271068 (patch)
tree0cd9748c05f2fe2103f337dc73be8c6853e64cd4 /gnu/packages/messaging.scm
parent8465732b7ce7b5f273c6e4bec71ea64819f71c3e (diff)
gnu: chatty: Fix indentation.
* gnu/packages/messaging.scm (chatty): Re-indent.
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm96
1 files changed, 48 insertions, 48 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 2af8c5b80a..0c327c7e18 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2805,10 +2805,10 @@ validating international phone numbers.")
(license license:asl2.0)))
(define-public chatty
- (package
- (name "chatty")
- (version "0.6.7")
- (source (origin
+ (package
+ (name "chatty")
+ (version "0.6.7")
+ (source (origin
(method git-fetch)
(uri (git-reference
(url "https://source.puri.sm/Librem5/chatty.git")
@@ -2823,51 +2823,51 @@ validating international phone numbers.")
(sha256
(base32
"11q07vjrrjf3k00kk41vm79brpq0qigz7l328br3g0li979kz32v"))))
- (build-system meson-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'skip-updating-desktop-database
- (lambda _
- (substitute* "meson.build"
- (("meson.add_install_script.*") ""))))
- (add-before 'check 'pre-check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- ;; One test requires a running Xorg server. Start one.
- (system "Xvfb :1 &")
- (setenv "DISPLAY" ":1")
- ;; HOME must be writable for writing configuration files.
- (setenv "HOME" "/tmp")))))))
- (native-inputs
- (list gettext-minimal
- `(,glib "bin")
- pkg-config
- protobuf
- xorg-server-for-tests))
- (inputs
- (list feedbackd
- folks
- gnome-desktop
- gsettings-desktop-schemas
- gspell
- json-glib
- libgcrypt
- libgee
- libhandy
- libolm
- libphonenumber
- modem-manager
- pidgin
- purple-mm-sms
- sqlite))
- (propagated-inputs
- (list adwaita-icon-theme evolution-data-server))
- (synopsis "Mobile client for XMPP and SMS messaging")
- (description "Chatty is a chat program for XMPP and SMS. It works on mobile
+ (build-system meson-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'skip-updating-desktop-database
+ (lambda _
+ (substitute* "meson.build"
+ (("meson.add_install_script.*") ""))))
+ (add-before 'check 'pre-check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; One test requires a running Xorg server. Start one.
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1")
+ ;; HOME must be writable for writing configuration files.
+ (setenv "HOME" "/tmp")))))))
+ (native-inputs
+ (list gettext-minimal
+ `(,glib "bin")
+ pkg-config
+ protobuf
+ xorg-server-for-tests))
+ (inputs
+ (list feedbackd
+ folks
+ gnome-desktop
+ gsettings-desktop-schemas
+ gspell
+ json-glib
+ libgcrypt
+ libgee
+ libhandy
+ libolm
+ libphonenumber
+ modem-manager
+ pidgin
+ purple-mm-sms
+ sqlite))
+ (propagated-inputs
+ (list adwaita-icon-theme evolution-data-server))
+ (synopsis "Mobile client for XMPP and SMS messaging")
+ (description "Chatty is a chat program for XMPP and SMS. It works on mobile
as well as on desktop platforms. It's based on libpurple and ModemManager.")
- (home-page "https://source.puri.sm/Librem5/chatty")
- (license license:gpl3+)))
+ (home-page "https://source.puri.sm/Librem5/chatty")
+ (license license:gpl3+)))
(define-public mosquitto
(package