summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-19 15:20:14 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-19 22:16:18 +0100
commitc18803f28dce7f9beb2c81aead253d86b05618e7 (patch)
treea24195ca081943ecd5ed241904437efff2e5d579 /gnu/packages/messaging.scm
parentaa954ec3664738f3d7b75a5ba96f787b93ad50c8 (diff)
gnu: gajim: Honour $GAJIM_PLUGIN_PATH.
This allows Gajim to find plug-ins installed with Guix. Reported at <http://issues.guix.gnu.org/44730>. However, at the time of pushing both packaged plug-ins (gajim-omemo and gajim-openpgp) require an unstable version of Gajim and will not load. * gnu/packages/messaging.scm (gajim)[arguments]: Replace the ‘add-plugin-dirs’ substitution phase with a... [source]: ...patch that won't silently break in the future. * gnu/packages/patches/gajim-honour-GAJIM_PLUGIN_PATH.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm13
1 files changed, 2 insertions, 11 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 624ad72c23..99131dcf05 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -743,7 +743,8 @@ of xmpppy.")
(version-major+minor version)
"/gajim-" version ".tar.gz"))
(sha256
- (base32 "1gfcp3b5nq43xxz5my8vfhfxnnli726j3hzcgwh9fzrzzd9ic3gx"))))
+ (base32 "1gfcp3b5nq43xxz5my8vfhfxnnli726j3hzcgwh9fzrzzd9ic3gx"))
+ (patches (search-patches "gajim-honour-GAJIM_PLUGIN_PATH.patch"))))
(build-system python-build-system)
(arguments
`(#:imported-modules
@@ -756,16 +757,6 @@ of xmpppy.")
(guix build utils))
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'add-plugin-dirs
- (lambda _
- (substitute* "gajim/common/configpaths.py"
- (("_paths\\['PLUGINS_USER'\\]\\]")
- "_paths['PLUGINS_USER']] + \
-([os.getenv('GAJIM_PLUGIN_PATH')] \
-if os.getenv('GAJIM_PLUGIN_PATH') \
-and Path(os.getenv('GAJIM_PLUGIN_PATH')).is_dir() \
-else [])"))
- #t))
(replace 'check
(lambda _
;; Tests require a running X server.