summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-07-24 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-07-24 02:00:00 +0200
commitd62b180ffd403df551329a653e526a8cc660b2d1 (patch)
tree99b1ce0ee3d88ffaa5a8022b13cd5c674e4aaed0 /gnu/packages/messaging.scm
parent56e17f6493b8ed9d0aeaeea69fb4caa1736ac620 (diff)
gnu: freetalk: Update to 4.2.
* gnu/packages/messaging.scm (freetalk): Update to 4.2. [arguments]: Remove unneeded "CFLAGS=-fcommon" from #:configure-flags. Don't explicitly return #t from phases. [inputs]: Update guile-2.0 to guile-3.0.
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index a593310e36..1581434ae8 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2081,19 +2081,17 @@ support, and more.")
(define-public freetalk
(package
(name "freetalk")
- (version "4.1")
+ (version "4.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/freetalk/freetalk-"
version ".tar.gz"))
(sha256
(base32
- "1rmrn7a1bb7vm26yaklrvx008a9qhwc32s57dwrlf40lv9gffwny"))))
+ "105mw7pg2mcp85r82cs4rv77nwvbw8025047364jzbq6lwllynxv"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags
- (list "CFLAGS=-fcommon")
- #:phases
+ `(#:phases
(modify-phases %standard-phases
;; For 'system' commands in Scheme code.
(add-after 'install 'wrap-program
@@ -2106,14 +2104,13 @@ support, and more.")
`("PATH" ":" prefix
,(map (lambda (dir)
(string-append dir "/bin"))
- (list bash coreutils less))))
- #t))))))
+ (list bash coreutils less))))))))))
(native-inputs
(list autoconf automake pkg-config texinfo))
(inputs
(list bash
glib
- guile-2.0
+ guile-3.0
less
loudmouth
readline))