summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-10-10 21:44:32 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-10-10 21:44:32 +0200
commit1c055d72585bd075e20ad0b41942d501d0b38656 (patch)
tree7baf50e22fb5f6c6d4b2fa7197596f68298eb691 /gnu/packages/messaging.scm
parent565e24c4e4710a5b81cce5cfb619b3e474e7f65c (diff)
parentffb4da7ad5c0e9cc969e0e47a3b8f4d2eba4d6f3 (diff)
Merge branch 'staging'
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm27
1 files changed, 13 insertions, 14 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index ae0bb69a15..7e093bc111 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -143,20 +143,19 @@ keys, no previous conversation is compromised.")
("python" ,python-2)
("perl" ,perl)))
(arguments
- `(#:phases (alist-cons-after
- 'install 'install-etc
- (lambda* (#:key (make-flags '()) #:allow-other-keys)
- (zero? (apply system* "make" "install-etc" make-flags)))
- (alist-replace
- 'configure
- ;; bitlbee's configure script does not tolerate many of the
- ;; variable settings that Guix would pass to it.
- (lambda* (#:key outputs #:allow-other-keys)
- (zero? (system* "./configure"
- (string-append "--prefix="
- (assoc-ref outputs "out"))
- "--otr=1")))
- %standard-phases))))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-etc
+ (lambda* (#:key (make-flags '()) #:allow-other-keys)
+ (zero? (apply system* "make" "install-etc" make-flags))))
+ (replace 'configure
+ ;; bitlbee's configure script does not tolerate many of the
+ ;; variable settings that Guix would pass to it.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (zero? (system* "./configure"
+ (string-append "--prefix="
+ (assoc-ref outputs "out"))
+ "--otr=1")))))))
(synopsis "IRC to instant messaging gateway")
(description "BitlBee brings IM (instant messaging) to IRC clients, for
people who have an IRC client running all the time and don't want to run an