summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-08-13 17:29:35 -0400
committerDavid Thompson <dthompson2@worcester.edu>2015-08-15 13:08:09 -0400
commita10052acd5e600425c98bfbd61255b235608c959 (patch)
treef78eaab48bc6982e88f662e32e7c91e3fdb2ce15 /gnu/packages/messaging.scm
parenta6d605e648643cd98582bf1e339bf60706d7c6c6 (diff)
gnu: Add znc.
* gnu/packages/messaging.scm (znc): New variable.
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm40
1 files changed, 38 insertions, 2 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 45110f5342..7263a3810f 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -21,7 +21,8 @@
(define-module (gnu packages messaging)
#:use-module ((guix licenses)
- #:select (gpl2+ gpl2 lgpl2.1 lgpl2.0+ bsd-2 non-copyleft))
+ #:select (gpl2+ gpl2 lgpl2.1 lgpl2.0+ bsd-2 non-copyleft
+ asl2.0))
#:use-module (guix utils)
#:use-module (guix packages)
#:use-module (guix download)
@@ -53,7 +54,8 @@
#:use-module (gnu packages check)
#:use-module (gnu packages admin)
#:use-module (gnu packages linux)
- #:use-module (gnu packages tls))
+ #:use-module (gnu packages tls)
+ #:use-module (gnu packages icu4c))
(define-public libotr
(package
@@ -357,4 +359,38 @@ If you lose control of your private keys, no previous conversation is
compromised.")
(license gpl2)))
+(define-public znc
+ (package
+ (name "znc")
+ (version "1.6.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://znc.in/releases/znc-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0h61nv5kx9k8prmhsffxhlprf7gjcq8vqhjjmqr6v3glcirkjjds"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; tries to download GoogleTest with wget
+ #:configure-flags '("--enable-python"
+ "--enable-perl"
+ "--enable-cyrus")))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("perl" ,perl)
+ ("python" ,python)))
+ (inputs
+ `(("openssl" ,openssl)
+ ("zlib" ,zlib)
+ ("icu4c" ,icu4c)
+ ("cyrus-sasl" ,cyrus-sasl)))
+ (home-page "http://znc.in")
+ (synopsis "IRC network bouncer")
+ (description "ZNC is an IRC network bouncer or BNC. It can detach the
+client from the actual IRC server, and also from selected channels. Multiple
+clients from different locations can connect to a single ZNC account
+simultaneously and therefore appear under the same nickname on IRC.")
+ (license asl2.0)))
+
;;; messaging.scm ends here