summaryrefslogtreecommitdiff
path: root/gnu/packages/monitoring.scm
diff options
context:
space:
mode:
authorM <matf@disr.it>2022-09-11 21:42:11 +0200
committerLudovic Courtès <ludo@gnu.org>2022-09-24 17:59:05 +0200
commit870422a15e81b32b1a805b264a79e3db9e57b486 (patch)
tree4673011688d3cbee21ea4b9e400d2845fd7f9e52 /gnu/packages/monitoring.scm
parent9b4d2147c78148a7b5dded8f4880e90101e0dbd1 (diff)
gnu: Add batsignal.
* gnu/packages/monitoring.scm (batsignal): New variable. Co-authored-by: ( <paren@disroot.org> Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/monitoring.scm')
-rw-r--r--gnu/packages/monitoring.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/monitoring.scm b/gnu/packages/monitoring.scm
index e2cdf7c448..51ead2fe9b 100644
--- a/gnu/packages/monitoring.scm
+++ b/gnu/packages/monitoring.scm
@@ -12,6 +12,8 @@
;;; Copyright © 2021 Raphaël Mélotte <raphael.melotte@mind.be>
;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
;;; Copyright © 2022 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2022 ( <paren@disroot.org>
+;;; Copyright © 2022 Mathieu Laparie <mlaparie@disr.it>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -50,6 +52,7 @@
#:use-module (gnu packages django)
#:use-module (gnu packages gd)
#:use-module (gnu packages gettext)
+ #:use-module (gnu packages gnome) ;libnotify
#:use-module (gnu packages image)
#:use-module (gnu packages mail)
#:use-module (gnu packages ncurses)
@@ -758,3 +761,46 @@ display resumes.
(description "StatsD is a friendly front-end to Graphite. This package
provides a simple Python client for the StatsD daemon.")
(license license:expat)))
+
+(define-public batsignal
+ (package
+ (name "batsignal")
+ (version "1.6.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/electrickite/batsignal")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0b1j6mljnqgxwr3id3r9shzhsjk5r0qdh9cxkvy1dm4kzbyc4dxq"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:make-flags
+ #~(list (string-append "PREFIX=" #$output)
+ (string-append "CC=" #$(cc-for-target)))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-cross-compile
+ (lambda _
+ (substitute* "Makefile"
+ (("pkg-config")
+ #$(pkg-config-for-target)))))
+ (delete 'configure)
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "./batsignal" "-v")))))))
+ (inputs (list libnotify))
+ (native-inputs (list pkg-config))
+ (home-page "https://github.com/electrickite/batsignal")
+ (synopsis "Power monitoring tool")
+ (description
+ "This package provides a daemon that monitors device power levels,
+notifying the user and optionally running a command when it reaches
+user-configured power thresholds. This can be used to force powering off a
+laptop when the battery gets below critical levels, instead of damaging the
+battery.")
+ (license license:isc)))
+