summaryrefslogtreecommitdiff
path: root/gnu/packages/mp3.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-01-25 15:21:09 -0500
committerLeo Famulari <leo@famulari.name>2021-01-25 15:40:55 -0500
commit68dd78e2e47248b3e1e7ba1807a92a8374b39097 (patch)
treed38564293f285d688a55b23e8a6424c6b26213b1 /gnu/packages/mp3.scm
parent8b55544212a90b0276df49596a3d373e5c2e8f5c (diff)
parent3f0af15131e524891df8c9f013f1be1597fe2d7e (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/mp3.scm')
-rw-r--r--gnu/packages/mp3.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
index c32b3cba11..34390d3696 100644
--- a/gnu/packages/mp3.scm
+++ b/gnu/packages/mp3.scm
@@ -82,6 +82,10 @@
;; remove option that is not supported by gcc any more
(substitute* "configure" ((" -fforce-mem") ""))
#t))
+ ;; Normally one should not add a pkg-config file if one is not provided
+ ;; by upstream developers, but Audacity expects a pkg-config file for
+ ;; this package, and other major GNU/Linux distributions already provide
+ ;; such a file.
(add-after 'install 'install-pkg-config
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -127,6 +131,10 @@ This package contains the library.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ ;; Normally one should not add a pkg-config file if one is not provided
+ ;; by upstream developers, but Audacity expects a pkg-config file for
+ ;; this package, and other major GNU/Linux distributions already provide
+ ;; such a file.
(add-after 'install 'install-pkg-config
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))