summaryrefslogtreecommitdiff
path: root/gnu/packages/mp3.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2014-10-23 23:46:59 -0500
committerEric Bavier <bavier@member.fsf.org>2014-10-26 13:03:53 -0500
commit35b9e4232c1b59568c9a76630251c1ea6a330ac4 (patch)
tree5572758f315e565ab7e9f3fe54867a8813645637 /gnu/packages/mp3.scm
parent3c42965b1ecd392da7691e5c7e25303ea385bf3d (diff)
gnu: Some cleanup based on lint checkers.
* gnu/packages/admin.scm, gnu/packages/aidc.scm, gnu/packages/algebra.scm, gnu/packages/apr.scm, gnu/packages/avahi.scm, gnu/packages/backup.scm, gnu/packages/base.scm, gnu/packages/calcurse.scm, gnu/packages/cdrom.scm, gnu/packages/check.scm, gnu/packages/compression.scm, gnu/packages/cook.scm, gnu/packages/crypto.scm, gnu/packages/cryptsetup.scm, gnu/packages/curl.scm, gnu/packages/cyrus-sasl.scm, gnu/packages/databases.scm, gnu/packages/doxygen.scm, gnu/packages/dwm.scm, gnu/packages/elf.scm, gnu/packages/emacs.scm, gnu/packages/feh.scm, gnu/packages/file.scm, gnu/packages/fish.scm, gnu/packages/flex.scm, gnu/packages/fltk.scm, gnu/packages/fontutils.scm, gnu/packages/games.scm, gnu/packages/gcal.scm, gnu/packages/gcc.scm, gnu/packages/geeqie.scm, gnu/packages/ghostscript.scm, gnu/packages/gimp.scm, gnu/packages/gl.scm, gnu/packages/glib.scm, gnu/packages/gnome.scm, gnu/packages/gnunet.scm, gnu/packages/gnupg.scm, gnu/packages/gperf.scm, gnu/packages/grub.scm, gnu/packages/gsasl.scm, gnu/packages/gtk.scm, gnu/packages/guile-wm.scm, gnu/packages/guile.scm, gnu/packages/hurd.scm, gnu/packages/icu4c.scm, gnu/packages/image.scm, gnu/packages/imagemagick.scm, gnu/packages/irssi.scm, gnu/packages/kde.scm, gnu/packages/libdaemon.scm, gnu/packages/libevent.scm, gnu/packages/libidn.scm, gnu/packages/libusb.scm, gnu/packages/linux.scm, gnu/packages/lout.scm, gnu/packages/lsh.scm, gnu/packages/lsof.scm, gnu/packages/lua.scm, gnu/packages/maths.scm, gnu/packages/mcrypt.scm, gnu/packages/mp3.scm, gnu/packages/netpbm.scm, gnu/packages/noweb.scm, gnu/packages/ocaml.scm, gnu/packages/openssl.scm, gnu/packages/pcre.scm, gnu/packages/pdf.scm, gnu/packages/pkg-config.scm, gnu/packages/pretty-print.scm, gnu/packages/python.scm, gnu/packages/qt.scm, gnu/packages/rsync.scm, gnu/packages/scheme.scm, gnu/packages/scrot.scm, gnu/packages/sdl.scm, gnu/packages/skribilo.scm, gnu/packages/ssh.scm, gnu/packages/stalonetray.scm, gnu/packages/tcl.scm, gnu/packages/tcsh.scm, gnu/packages/telephony.scm, gnu/packages/texlive.scm, gnu/packages/tor.scm, gnu/packages/valgrind.scm, gnu/packages/version-control.scm, gnu/packages/vim.scm, gnu/packages/vpn.scm, gnu/packages/w3m.scm, gnu/packages/web.scm, gnu/packages/wordnet.scm, gnu/packages/xiph.scm, gnu/packages/xml.scm, gnu/packages/xorg.scm, gnu/packages/zile.scm, gnu/packages/zip.scm, gnu/packages/zsh.scm [synopsis, description]: Adjust according to lint checkers. * gnu/packages/fltk.scm (fltk)[source]: Wrap long line in uri. * /gnu/packages/xiph.scm (libogg, libtheora, vorbis-tools)[source]: Same.
Diffstat (limited to 'gnu/packages/mp3.scm')
-rw-r--r--gnu/packages/mp3.scm34
1 files changed, 17 insertions, 17 deletions
diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
index 3860601623..54b81955d9 100644
--- a/gnu/packages/mp3.scm
+++ b/gnu/packages/mp3.scm
@@ -58,7 +58,7 @@
;; remove option that is not supported by gcc any more
(substitute* "configure" ((" -fforce-mem") "")))
%standard-phases)))
- (synopsis "libmad, an MPEG audio decoder")
+ (synopsis "MPEG audio decoder")
(description
"MAD (MPEG Audio Decoder) supports MPEG-1 and the MPEG-2 extension to
lower sampling frequencies, as well as the de facto MPEG 2.5 format.
@@ -83,9 +83,9 @@ This package contains the library.")
"0lb1w883dc46dajbdvnia5870brl5lvnlk7g7y58y9wpg5p4znk3"))))
(build-system gnu-build-system)
(inputs `(("zlib" ,zlib)))
- (synopsis "libid3tag, a library for reading ID3 tags")
+ (synopsis "Library for reading ID3 tags")
(description
- "libid3tag is a library for reading ID3 tags, both ID3v1 and the various
+ "Libid3tag is a library for reading ID3 tags, both ID3v1 and the various
versions of ID3v2")
(license license:gpl2+)
(home-page "http://www.underbit.com/products/mad/")))
@@ -119,10 +119,10 @@ versions of ID3v2")
(substitute* "examples/test_io.cpp"
(("dami;") "dami;\nusing namespace std;")))
%standard-phases)))
- (synopsis "a library for reading, writing, and manipulating ID3v1 and ID3v2 tags")
+ (synopsis "Library for reading, writing, and manipulating ID3v1 and ID3v2 tags")
(description
- "id3lib is a cross-platform software development library for reading,
-writing, and manipulating ID3v1 and ID3v2 tags. It is an on-going project
+ "Id3lib is a cross-platform software development library for reading,
+writing, and manipulating ID3v1 and ID3v2 tags. It is an on-going project
whose primary goals are full compliance with the ID3v2 standard, portability
across several platforms, and providing a powerful and feature-rich API with
a highly stable and efficient implementation.")
@@ -150,12 +150,12 @@ a highly stable and efficient implementation.")
("pcre" ,pcre)))
(native-inputs
`(("pkg-config" ,pkg-config)))
- (synopsis "libmp3splt, a library for splitting mp3 and ogg vorbis files")
+ (synopsis "Library for splitting mp3 and ogg vorbis files")
(description
"Mp3splt is a utility to split mp3 and ogg vorbis files selecting a begin
-and an end time position, without decoding. For splitting an album, one may
+and an end time position, without decoding. For splitting an album, one may
select split points and filenames manually or obtain them automatically from
-CDDB (internet or a local file) or from .cue files. The tool also supports
+CDDB (internet or a local file) or from .cue files. The tool also supports
automatic silence split, that can be used also to adjust cddb/cue splitpoints.
This package contains the library.")
@@ -176,12 +176,12 @@ This package contains the library.")
"106dnka56prlc9nsfh300f8841am2lmkwlzgl9lkr25mgnc35wwh"))))
(build-system gnu-build-system)
(inputs `(("libmp3splt" ,libmp3splt)))
- (synopsis "mp3splt, a utiliy for splitting mp3 and ogg vorbis files")
+ (synopsis "Utiliy for splitting mp3 and ogg vorbis files")
(description
"Mp3splt is a utility to split mp3 and ogg vorbis files selecting a begin
-and an end time position, without decoding. For splitting an album, one may
+and an end time position, without decoding. For splitting an album, one may
select split points and filenames manually or obtain them automatically from
-CDDB (internet or a local file) or from .cue files. The tool also supports
+CDDB (internet or a local file) or from .cue files. The tool also supports
automatic silence split, that can be used also to adjust cddb/cue splitpoints.
This package contains the binary.")
@@ -207,7 +207,7 @@ This package contains the binary.")
(home-page "http://www.mpg123.org/")
(synopsis "Console MP3 player and decoder library")
(description
- "mpg123 is a real time MPEG 1.0/2.0/2.5 audio player/decoder for layers
+ "Mpg123 is a real time MPEG 1.0/2.0/2.5 audio player/decoder for layers
1,2 and 3 (MPEG 1.0 layer 3 aka MP3 most commonly tested). It comes with a
command-line tool as well as a C library, libmpg123.")
(license license:lgpl2.1)))
@@ -232,7 +232,7 @@ command-line tool as well as a C library, libmpg123.")
("libao" ,ao)))
(home-page "http://mpg321.sourceforge.net/")
(synopsis "Command-line MP3 player")
- (description "mpg321 is a command-line mp3 player. mpg321 is used for
+ (description "Mpg321 is a command-line mp3 player. mpg321 is used for
frontends, as an mp3 player and as an mp3 to wave file decoder (primarily for
use with CD-recording software).")
(license license:gpl2)))
@@ -285,8 +285,8 @@ use with CD-recording software).")
(synopsis "GTK program to rip and encode CD audio tracks")
(description
"RipperX is a GTK program to rip CD audio tracks and encode them to the
-Ogg, MP3, or FLAC formats. It's goal is to be easy to use, requiring only
-a few mouse clicks to convert an entire album. It supports CDDB lookups
+Ogg, MP3, or FLAC formats. Its goal is to be easy to use, requiring only
+a few mouse clicks to convert an entire album. It supports CDDB lookups
for album and track information.")
(license license:gpl2)
(home-page "http://sourceforge.net/projects/ripperx/")))
@@ -349,6 +349,6 @@ format.")
(home-page "http://mpc123.sourceforge.net/")
(synopsis "Audio player for Musepack-formatted files")
(description
- "mpc123 is a command-line player for files in the Musepack audio
+ "Mpc123 is a command-line player for files in the Musepack audio
compression format (.mpc files.)")
(license license:gpl2+)))