summaryrefslogtreecommitdiff
path: root/gnu/packages/mpd.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-04-26 17:07:32 -0400
committerLeo Famulari <leo@famulari.name>2016-04-30 14:38:49 -0400
commitc7794307f1bb99a68d93840a74fda7a64189a381 (patch)
tree3e37bc56da24abfb0db282c9128866520160fac9 /gnu/packages/mpd.scm
parent324efb88880834bbe9bb55387b63dafd600e93e9 (diff)
gnu: ncmpcpp: Remove bootstrapping phase.
* gnu/packages/mpd.scm (ncmpcpp)[arguments]: Remove 'autogen' phase. [native-inputs]: Remove autoconf, automake, and libtool.
Diffstat (limited to 'gnu/packages/mpd.scm')
-rw-r--r--gnu/packages/mpd.scm14
1 files changed, 2 insertions, 12 deletions
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index 63cb16fccb..4860325b56 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -42,7 +42,6 @@
#:use-module (gnu packages ncurses)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
- #:use-module (gnu packages autotools)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages databases)
#:use-module (gnu packages video)
@@ -198,19 +197,10 @@ terminal using ncurses.")
("taglib" ,taglib)
("icu4c" ,icu4c)))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("automake" ,automake)
- ("autoconf" ,autoconf)
- ("libtool" ,libtool)))
+ `(("pkg-config" ,pkg-config)))
(arguments
'(#:configure-flags
- '("BOOST_LIB_SUFFIX=" "--with-taglib")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'autogen
- (lambda _
- (setenv "NOCONFIGURE" "true")
- (zero? (system* "sh" "autogen.sh")))))))
+ '("BOOST_LIB_SUFFIX=" "--with-taglib")))
(synopsis "Featureful ncurses based MPD client inspired by ncmpc")
(description "Ncmpcpp is an mpd client with a UI very similar to ncmpc,
but it provides new useful features such as support for regular expressions