summaryrefslogtreecommitdiff
path: root/gnu/packages/multiprecision.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-03-04 11:58:50 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-03-05 08:54:13 +0200
commitf9207c33780eaf97acdc209ef8bf5125c784a6f2 (patch)
tree4661e4704e5e2c48fbb2f1c91a754fc79c865a43 /gnu/packages/multiprecision.scm
parentcd042f3a8efe85754a35979fadb392157ec12367 (diff)
gnu: libtommath: Update to 1.2.1.
* gnu/packages/multiprecision.scm (libtommath): Update to 1.2.1. [source]: Remove patch. [arguments]: Remove trailing #t from phases. [properties]: Add upstream-name, lint-hidden-cve. * gnu/packages/patches/libtommath-integer-overflow.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it. Change-Id: I4c1de43b4083e0649fcb493a5c304736e41ab4b8
Diffstat (limited to 'gnu/packages/multiprecision.scm')
-rw-r--r--gnu/packages/multiprecision.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/multiprecision.scm b/gnu/packages/multiprecision.scm
index 18a269ddc7..daa3144bd3 100644
--- a/gnu/packages/multiprecision.scm
+++ b/gnu/packages/multiprecision.scm
@@ -455,7 +455,7 @@ number generators, public key cryptography and a plethora of other routines.")
(define-public libtommath
(package
(name "libtommath")
- (version "1.2.0")
+ (version "1.2.1")
(outputs '("out" "static"))
(source
(origin
@@ -464,8 +464,7 @@ number generators, public key cryptography and a plethora of other routines.")
"download/v" version "/ltm-" version ".tar.xz"))
(sha256
(base32
- "1c8q1qy88cjhdjlk3g24mra94h34c1ldvkjz0n2988c0yvn5xixp"))
- (patches (search-patches "libtommath-integer-overflow.patch"))))
+ "07qdxnmp5bhfw5za6mr2l2w0vb7494v9zs9h5vp6y9vlngbjaq4q"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -476,13 +475,11 @@ number generators, public key cryptography and a plethora of other routines.")
;; We want the shared library by default so force it to be the
;; default makefile target.
(delete-file "makefile")
- (symlink "makefile.shared" "makefile")
- #t))
+ (symlink "makefile.shared" "makefile")))
(add-after 'install 'remove-static-library
(lambda* (#:key outputs #:allow-other-keys)
(delete-file (string-append (assoc-ref outputs "out")
- "/lib/libtommath.a"))
- #t))
+ "/lib/libtommath.a"))))
(replace 'check
(lambda* (#:key tests? test-target make-flags #:allow-other-keys)
(when tests?
@@ -504,4 +501,6 @@ number generators, public key cryptography and a plethora of other routines.")
integer library written entirely in C. It's designed to provide an API that is
simple to work with that provides fairly efficient routines that build out of
the box without configuration.")
+ (properties `((upstream-name . "ltm")
+ (lint-hidden-cve . ("CVE-2023-36328"))))
(license unlicense)))