summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorSughosha <Sughosha@proton.me>2023-06-10 08:28:15 +0000
committerChristopher Baines <mail@cbaines.net>2023-06-12 19:51:39 +0100
commita44cd79545cd520c5bd0bcc0c399bb83709fe891 (patch)
treeb1ac21aefe92bea15c25357350705d7479a0b639 /gnu/packages/music.scm
parent86d7c5730cd63406690ae71a19930bc8c74db4be (diff)
gnu: musikcube: Update to 3.0.1.
* gnu/packages/music.scm (musikcube): Update to 3.0.1. [arguments]<#:configure-flags>: Remove "-DENABLE_BUNDLED_TAGLIB=false". [native-inputs]: Add "asio". [inputs]: Replace "ncurses" with "ncurses/tinfo" and add "libgme", "libogg", "libvorbis" and "pipewire". Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm14
1 files changed, 9 insertions, 5 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index b7369391db..67d170997d 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -159,6 +159,7 @@
#:use-module (gnu packages mpd)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages netpbm)
+ #:use-module (gnu packages networking)
#:use-module (gnu packages pcre)
#:use-module (gnu packages pdf)
#:use-module (gnu packages perl)
@@ -7095,7 +7096,7 @@ choice.")
(define-public musikcube
(package
(name "musikcube")
- (version "0.96.10")
+ (version "3.0.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -7104,13 +7105,12 @@ choice.")
(file-name (git-file-name name version))
(sha256
(base32
- "06myr83x8jvzlzchg3jsw1163n2lcsbmb176zgnx7xxa26jpdbh1"))))
+ "09q15xlssgg67zg5m0q574k3al2pdjdnm1580mlf0wzr6a021fnd"))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f ; No test suite
#:configure-flags
'("-DCMAKE_BUILD_TYPE=Release"
- "-DENABLE_BUNDLED_TAGLIB=false"
;; Use the "wide" ncurses headers but don't look for them in an
;; ncursesw directory. For more info:
;; https://github.com/clangen/musikcube/wiki/building#compiler-cannot-find-ncurseswcursesh
@@ -7118,7 +7118,7 @@ choice.")
;; We will strip the binaries ourselves in the 'strip' phase.
"-DDISABLE_STRIP=true")))
(native-inputs
- (list pkg-config))
+ (list asio pkg-config))
(inputs
(list alsa-lib
boost
@@ -7126,10 +7126,14 @@ choice.")
ffmpeg-4
lame
libev
+ libgme
libmicrohttpd
+ libogg
libopenmpt
- ncurses
+ libvorbis
+ ncurses/tinfo
openssl
+ pipewire
pulseaudio
taglib
zlib))