summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-29 19:02:35 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-29 19:02:35 +0100
commit80983df357856fe4e65e384a655e466164e049a1 (patch)
tree6aa660343b43ebdde84946ee4057538558f962d4 /gnu/packages/music.scm
parent3bf428065916f1a47c5ed12f5622f0eff4123644 (diff)
gnu: python2-discogs-client: Remove python2-setuptools from inputs.
* gnu/packages/music.scm (python2-discogs-client): Use simply "package-with-python2". Remove inheriting from python-discogs-client since adding python2-setuptools to [native-inputs] has been the sole reason for inheriting. (python-discogs-client) Remove the now needless [properties] "python2-variant".
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm10
1 files changed, 2 insertions, 8 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 3f2018ef46..6950d8884f 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2471,13 +2471,7 @@ you to query the Discogs database for information on artists, releases, labels,
users, Marketplace listings, and more. It also supports OAuth 1.0a
authorization, which allows you to change user data such as profile information,
collections and wantlists, inventory, and orders.")
- (license license:bsd-2)
- (properties `((python2-variant . ,(delay python2-discogs-client))))))
+ (license license:bsd-2)))
(define-public python2-discogs-client
- (let ((base (package-with-python2
- (strip-python2-variant python-discogs-client))))
- (package (inherit base)
- (native-inputs
- `(("python2-setuptools" ,python2-setuptools)
- ,@(package-native-inputs base))))))
+ (package-with-python2 python-discogs-client))