summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-10-12 20:05:58 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-10-13 22:50:44 +0200
commit4d4bfdc29b9d919fc430879e222876dad7743e16 (patch)
treeb86147ae75f122835d68dfe341b48dc2e03510e1 /gnu/packages/music.scm
parent4d95cd306b3dca258befbd38da0359f7e4ad10c2 (diff)
gnu: Add gx-push-pull-lv2.
* gnu/packages/music.scm (gx-push-pull-lv2): New variable.
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 4a320d1960..376819aeba 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2066,3 +2066,23 @@ overdrive effect."))))
(synopsis "Clean boost with a 3-knob tonestack")
(description "This package provides the LV2 plugin \"GxToneMender\", a
clean boost effect with a 3-knob tonestack."))))
+
+(define-public gx-push-pull-lv2
+ (let ((commit "7f76ae2068498643ac8671ee0930b13ee3fd8eb5")
+ (revision "1"))
+ (package (inherit gx-guvnor-lv2)
+ (name "gx-push-pull-lv2")
+ (version (string-append "0-" revision "." (string-take commit 9)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/brummer10/GxPushPull.lv2")
+ (commit commit)))
+ (sha256
+ (base32
+ "12f5hwck2irph0gjbj8xy8jqcqdwb8l1hlwf29k0clz52h1jhb5q"))
+ (file-name (string-append name "-" version "-checkout"))))
+ (home-page "https://github.com/brummer10/GxPushPull.lv2")
+ (synopsis "Octave up push pull transistor fuzz simulation")
+ (description "This package provides the LV2 plugin \"GxPushPull\", a
+simulation of a push pull transistor fuzz effect with added high octave."))))