summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2016-09-10 10:27:34 -0400
committerKei Kebreau <kei@openmailbox.org>2016-09-13 10:31:40 -0400
commit89bcf3fcc92323d8116b6fd4d80bbfb48447dd47 (patch)
treede050c204b0ffad0ad2ba95f7f86a597b4534d1b /gnu/packages/music.scm
parent23de5cbd1487747a2d690ee3ac7630142a7eaeb8 (diff)
gnu: Add schismtracker.
* gnu/packages/music.scm (schismtracker): New variable.
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 88743aa14d..f2945646fd 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1638,6 +1638,52 @@ for improved Amiga ProTracker 2/3 compatibility.")
;; 'src/milkyplay' is under Modified BSD, the rest is under GPL3 or later.
(license (list license:bsd-3 license:gpl3+))))
+(define-public schismtracker
+ (package
+ (name "schismtracker")
+ (version "20160521")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/" name "/" name "/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0c6r24wm3rldm4j8cskl9xnixj3rwi3lnrhckw5gv43wpy6h4jcz"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Remove use of __DATE__ and __TIME__ for reproducibility.
+ `(substitute* "schism/version.c"
+ (("Schism Tracker build %s %s.*$")
+ (string-append "Schism Tracker version " ,version "\");"))))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'autoconf
+ (lambda _ (zero? (system* "autoreconf" "-vfi"))))
+ (add-before 'configure 'link-libm
+ (lambda _ (setenv "LIBS" "-lm") #t)))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("python" ,python)))
+ (inputs
+ `(("alsa-lib" ,alsa-lib) ; for asound dependency
+ ("libx11" ,libx11)
+ ("libxext" ,libxext)
+ ("sdl" ,sdl)))
+ (home-page "http://schismtracker.org")
+ (synopsis "Oldschool sample-based music composition tool")
+ (description
+ "Schism Tracker is a reimplementation of Impulse Tracker, a program used to
+create high quality music without the requirements of specialized, expensive
+equipment, and with a unique \"finger feel\" that is difficult to replicate in
+part. The player is based on a highly modified version of the ModPlug engine,
+with a number of bugfixes and changes to improve IT playback.")
+ (license license:gpl2+)))
+
(define-public moc
(package
(name "moc")