summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-08-08 01:31:42 -0400
committerLeo Famulari <leo@famulari.name>2018-08-16 02:54:10 -0400
commite42ba3daefc4a3d740ae4c2b01e39c67a9190809 (patch)
treec6e8a741b5d6ca2c753842a56b599e7e6894e4e0 /gnu/packages/music.scm
parent666da84f0f54d3e2f1ab6b6c14ebd9899a47dd50 (diff)
gnu: Add lpd8editor.
* gnu/packages/music.scm (lpd8editor): New variable.
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm38
1 files changed, 37 insertions, 1 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 2b8ff451bb..599a1d8943 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
;;; Copyright © 2016 Al McElrath <hello@yrns.org>
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2016, 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2017 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
@@ -4222,3 +4222,39 @@ discard.
discard bad quality ones.
@end itemize\n")
(license license:expat))))
+
+(define-public lpd8editor
+ (package
+ (name "lpd8editor")
+ (version "0.0.12")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/charlesfleche/lpd8editor.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1v3fz8h1zs7kkl80faah79pp6yqwz0j7bkv3dbmh2hp42zbfiz1q"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'setenv
+ (lambda _
+ (setenv "INSTALL_PREFIX"
+ (assoc-ref %outputs "out"))))
+ (delete 'configure) ; no configure script
+ (add-before 'build 'qmake
+ (lambda _ (invoke "qmake"))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("alsa" ,alsa-lib)
+ ("qtbase" ,qtbase)
+ ("qtsvg" ,qtsvg)))
+ (synopsis "Graphical editor for the Akai LPD8 MIDI controller")
+ (description "lpd8editor is a graphical patch editor for the Akai LPD8 MIDI
+controller.")
+ (home-page "https://github.com/charlesfleche/lpd8editor")
+ (license license:expat)))