summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorSughosha <sughosha@proton.me>2022-07-01 17:53:18 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-07-01 19:03:48 +0200
commit3b19dbd703685c3457e4ab997076009175927a7a (patch)
treec020f961361f70be62bd35b050135dddf404f236 /gnu/packages/music.scm
parent0fce0b9267393664f8007f7fac54a7dbe8d68906 (diff)
gnu: sorcer: Update to 1.1.3-1.cc7f6f5.
* gnu/packages/music.scm (sorcer): Update to 1.1.3-1.cc7f6f5. [source]: Fetch with git; remove generated C++ file. [native-inputs]: Replace faust with faust-0.9.67. This update fixes the building of the package. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm77
1 files changed, 40 insertions, 37 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index e0522e40f5..e337372c2a 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5056,44 +5056,47 @@ OSC connections.")
(license license:artistic2.0)))
(define-public sorcer
- (package
- (name "sorcer")
- (version "1.1.3")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/openAVproductions/"
- "openAV-Sorcer/archive/release-"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "07iyqj28wm0xc4arrq893bm12xjpz65db7ynrlmf6w8krg8wjmd0"))))
- (build-system cmake-build-system)
- (arguments
- `(#:tests? #f ; no tests included
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'remove-architecture-specific-flags
- (lambda _
- (substitute* "CMakeLists.txt"
- (("-msse2 -mfpmath=sse") ""))
- #t))
- (add-after 'unpack 'build-faust-sources
- (lambda* (#:key inputs #:allow-other-keys)
- (with-directory-excursion "faust"
- (delete-file "main.cpp")
- (invoke "faust" "-i"
- "-a" "lv2synth.cpp"
- "-o" "main.cpp" "main.dsp")))))))
- (inputs
- (list boost lv2 ntk))
- (native-inputs
- (list faust pkg-config))
- (home-page "http://openavproductions.com/sorcer/")
- (synopsis "Wavetable LV2 plugin synth")
- (description "Sorcer is a wavetable LV2 plugin synthesizer, targeted at
+ (let ((revision "1")
+ ;; The last release was in 2016. Since then a couple of commits have
+ ;; been added to fix build problems, so we take this arbitrary recent
+ ;; commit.
+ (commit "cc7f6f58af3188a8620b90fdad6e8ca5d026f543"))
+ (package
+ (name "sorcer")
+ (version (git-version "1.1.3" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/openAVproductions/openAV-Sorcer")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ryaglp2pzln2bm0pwc5p9lb2nk0x4wmrs4c4cp6d2m2hhk82yk7"))
+ (snippet
+ '(delete-file "faust/main.cpp"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ;no tests included
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-architecture-specific-flags
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("-msse2 -mfpmath=sse") ""))))
+ (add-after 'unpack 'build-faust-sources
+ (lambda* (#:key inputs #:allow-other-keys)
+ (with-directory-excursion "faust"
+ (invoke "faust" "-i"
+ "-a" "lv2synth.cpp"
+ "-o" "main.cpp" "main.dsp")))))))
+ (inputs (list boost lv2 ntk))
+ (native-inputs (list faust-0.9.67 pkg-config))
+ (home-page "http://openavproductions.com/sorcer/")
+ (synopsis "Wavetable LV2 plugin synth")
+ (description "Sorcer is a wavetable LV2 plugin synthesizer, targeted at
the electronic or dubstep genre.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public sonivox-eas
(package