summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-10-09 23:41:25 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-10-10 17:55:18 +0200
commitfd024ba0f5d51dedb8550213104bc967df07eed6 (patch)
treee75c1d1bd7d58ee515438ce1b2836109134d56db /gnu/packages/networking.scm
parent4459c05af73e2eb299e07a5991c1e689e8b8921d (diff)
gnu: wireshark: Update to 4.0.0.
* gnu/packages/networking.scm (wireshark): Update to 4.0.0. [arguments]<#:phases>: Skip checks differently, as the previous way doesn't work anymore. [inputs]: Add pcre2.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm25
1 files changed, 14 insertions, 11 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 8311541b23..def28b6172 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1760,27 +1760,29 @@ of the same name.")
(define-public wireshark
(package
(name "wireshark")
- (version "3.6.7")
+ (version "4.0.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.wireshark.org/download/src/wireshark-"
version ".tar.xz"))
(sha256
- (base32 "1idpxnh8vrvan3g0ymaa24bd4iyxi19xrr76sdrrpxx2r8shmqfc"))))
+ (base32 "1vddvizywy6kfxg0i3m0627f675i7sdp7k3ld9sjlp78hppjbh9x"))))
(build-system cmake-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'remove-failing-test
- ;; Skip test suite failing with "Program reassemble_test is not
- ;; available" and alike errors. Also skip test suite failing with
- ;; "AssertionError: Program extcap/sdjournal is not available"
- ;; error.'
- (lambda _
- (substitute* "CMakeLists.txt"
- (("suite_unittests" all) (string-append "# " all))
- (("suite_extcaps" all) (string-append "# " all))))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ ;; Skip test suite failing with "Program reassemble_test is not
+ ;; available" and alike errors. Also skip test suite failing
+ ;; with "AssertionError: Program extcap/sdjournal is not
+ ;; available" error.'
+ (when tests?
+ (invoke "ctest"
+ "-E"
+ (string-join (list "suite_unittests" "suite_extcaps")
+ "|"))))))
;; Build process chokes during `validate-runpath' phase.
;;
;; Errors are like the following:
@@ -1809,6 +1811,7 @@ of the same name.")
mit-krb5
`(,nghttp2 "lib")
minizip
+ pcre2
qtbase-5
qtmultimedia-5
qtsvg-5