summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2024-02-18 16:54:22 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-24 18:09:16 +0000
commit04c558dd1b76099fc4e749b77ca38f169320b2e8 (patch)
tree8eedc8977fb88161f12f41bb8c71582a90b2cee4 /gnu/packages/networking.scm
parent313458c58c3fd89705081e1721e7c6fe7818d813 (diff)
gnu: wireshark: Update to 4.2.3 [security-fixes].
* gnu/packages/networking.scm (wireshark): Update to 4.2.3. [build-system]: Switch to qt-build-system. [arguments]: Drop unnecessary -DUSE_qt6 from #:configure-flags. Drop test workaround. [inputs]: Add required inputs lua-5.2 and speexdsp. Change-Id: Ib859c0e64377b2920a4eacc2ef4d4393e34426e0 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm24
1 files changed, 11 insertions, 13 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index fb13072f39..640f3483dc 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -179,6 +179,7 @@
#:use-module (gnu packages valgrind)
#:use-module (gnu packages web)
#:use-module (gnu packages wxwidgets)
+ #:use-module (gnu packages xiph)
#:use-module (gnu packages xml)
#:use-module (ice-9 match))
@@ -1774,23 +1775,23 @@ of the same name.")
(define-public wireshark
(package
(name "wireshark")
- (version "4.0.7")
+ (version "4.2.3")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.wireshark.org/download/src/wireshark-"
version ".tar.xz"))
(sha256
- (base32 "0xw7iagh37y02qgzgmb2xf1qagbphv5lpgra8lq3x0pzrc27p7x7"))))
- (build-system cmake-build-system)
+ (base32 "04aqg5w8yfikqc1446c2zr2h4yyd5napwkhskdvr2galdycxb2wm"))))
+ (build-system qt-build-system)
(arguments
(list
;; This causes the plugins to register runpaths for the wireshark
;; libraries, which would otherwise cause the validate-runpath phase to
;; fail.
- #:configure-flags #~(list (string-append "-DCMAKE_MODULE_LINKER_FLAGS="
- "-Wl,-rpath=" #$output "/lib")
- "-DUSE_qt6=ON")
+ #:qtbase qtbase
+ #:configure-flags
+ #~(list (string-append "-DCMAKE_MODULE_LINKER_FLAGS=-Wl,-rpath=" #$output "/lib"))
#:phases
#~(modify-phases %standard-phases
(replace 'check
@@ -1799,11 +1800,7 @@ of the same name.")
(invoke "ctest" "-VV"
"-j" (if parallel-tests?
(number->string (parallel-job-count))
- "1")
- ;; Skip the suite_extcaps.case_extcaps.test_sdjournal
- ;; test as it requires sdjournal (from systemd) and
- ;; fails.
- "-E" "suite_extcaps")))))))
+ "1"))))))))
(inputs
(list c-ares
glib
@@ -1816,7 +1813,7 @@ of the same name.")
libssh
libxml2
lz4
- lua
+ lua-5.2
mit-krb5
`(,nghttp2 "lib")
minizip
@@ -1827,6 +1824,7 @@ of the same name.")
qtsvg
sbc
snappy
+ speexdsp
zlib
`(,zstd "lib")))
(native-inputs
@@ -1842,7 +1840,7 @@ of the same name.")
(description "Wireshark is a network protocol analyzer, or @dfn{packet
sniffer}, that lets you capture and interactively browse the contents of
network frames.")
- (home-page "https://www.wireshark.org/")
+ (home-page "https://www.wireshark.org")
(license license:gpl2+)))
(define-public fping