summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-09 01:11:52 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-09 12:48:29 -0400
commit523d66f1835b180aa9632ad644cf65a41abacb4f (patch)
tree5c7476ac5738a5d23034ec6121e6a642d50404a2 /gnu/packages/networking.scm
parentcf34f40420990e57c267131af21d38b0f2557d84 (diff)
gnu: libnice: Update to 0.1.21.
* gnu/packages/networking.scm (libnice): Update to 0.1.21. [arguments]: Use gexps. [native-inputs]: Remove labels.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm141
1 files changed, 69 insertions, 72 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index eb2cccc57c..8571c57800 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -26,7 +26,7 @@
;;; Copyright © 2018, 2020-2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2018, 2020, 2021, 2022 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
-;;; Copyright © 2019, 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2019, 2020, 2021, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2019 Vasile Dumitrascu <va511e@yahoo.com>
;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2019 Timotej Lazar <timotej.lazar@araneo.si>
@@ -413,79 +413,76 @@ Android, and ChromeOS.")
(license license:lgpl2.1+)))
(define-public libnice
- ;; The latest release is old and randomly fails tests with GStreamer 1.18.5,
- ;; such as: "test-bind: ../libnice-0.1.18/stun/tests/test-bind.c:234:
- ;; bad_responses: Assertion `len >= 20' failed"
- (let ((revision "0")
- (commit "47a96334448838c43d7e72f4ef51b317befbfae1"))
- (package
- (name "libnice")
- (version (git-version "0.1.18" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.freedesktop.org/libnice/libnice")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "19ypjazslmsb9vqs2wyyzvi72h5jbn16dbng7pxh485djdrmgcg4"))))
- (build-system meson-build-system)
- (outputs '("out" "doc"))
- (arguments
- `(#:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
- #:configure-flags
- (list
- "-Dgtk_doc=enabled")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'disable-failing-tests
- (lambda _
- (substitute* "tests/meson.build"
- ;; ‘test-set-port-range.c:66:main: assertion failed:
- ;; (nice_agent_gather_candidates (agent, stream1))’
- (("'test-set-port-range'" all)
- (string-append "# " all))
- ;; The following test is disabled as it fails in a
- ;; nondeterministic fashion (see:
- ;; https://gitlab.freedesktop.org/libnice/libnice/-/issues/151).
- (("'test-bsd'" all)
- (string-append "# " all)))
- (substitute* "stun/tests/meson.build"
- ;; test-bind.c:234: bad_responses: Assertion `len >= 20'
- ;; failed (see:
- ;; https://gitlab.freedesktop.org/libnice/libnice/-/issues/150).
- (("'bind', ")
- ""))))
- (add-after 'install 'move-docs
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (doc (assoc-ref outputs "doc")))
- (mkdir-p (string-append doc "/share"))
- (rename-file
- (string-append out "/share/gtk-doc")
- (string-append doc "/share/gtk-doc"))))))))
- (native-inputs
- `(("glib:bin" ,glib "bin")
- ("gobject-introspection" ,gobject-introspection)
- ("graphviz" ,graphviz)
- ("gtk-doc" ,gtk-doc/stable)
- ("pkg-config" ,pkg-config)))
- (inputs
- (list gstreamer gst-plugins-base libnsl))
- (propagated-inputs
- (list glib glib-networking gnutls))
- (synopsis "GLib ICE implementation")
- (description "LibNice is a library that implements the Interactive
+ (package
+ (name "libnice")
+ (version "0.1.21")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/libnice/libnice")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0zxh1mdrl4p2vih8f4yqzm3pp4jsmc8aq7l43dlndaz4sj4c8j44"))))
+ (build-system meson-build-system)
+ (outputs '("out" "doc"))
+ (arguments
+ (list
+ #:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
+ #:configure-flags
+ #~(list"-Dgtk_doc=enabled")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda _
+ (substitute* "tests/meson.build"
+ ;; ‘test-set-port-range.c:66:main: assertion failed:
+ ;; (nice_agent_gather_candidates (agent, stream1))’
+ (("'test-set-port-range'" all)
+ (string-append "# " all))
+ ;; The following test is disabled as it fails in a
+ ;; nondeterministic fashion (see:
+ ;; https://gitlab.freedesktop.org/libnice/libnice/-/issues/151).
+ (("'test-bsd'" all)
+ (string-append "# " all)))
+ (substitute* "stun/tests/meson.build"
+ ;; test-bind.c:234: bad_responses: Assertion `len >= 20'
+ ;; failed (see:
+ ;; https://gitlab.freedesktop.org/libnice/libnice/-/issues/150).
+ (("'bind', ")
+ ""))))
+ (add-after 'install 'move-docs
+ (lambda _
+ (mkdir-p (string-append #$output:doc "/share"))
+ (rename-file
+ (string-append #$output "/share/gtk-doc")
+ (string-append #$output:doc "/share/gtk-doc")))))))
+ (native-inputs
+ (list `(,glib "bin")
+ gobject-introspection
+ graphviz
+ gtk-doc/stable
+ pkg-config))
+ (inputs
+ (list gstreamer
+ gst-plugins-base
+ libnsl))
+ (propagated-inputs
+ (list glib
+ glib-networking
+ gnutls))
+ (synopsis "GLib ICE implementation")
+ (description "LibNice is a library that implements the Interactive
Connectivity Establishment (ICE) standard (RFC 5245 & RFC 8445). It provides a
GLib-based library, libnice, as well as GStreamer elements to use it.")
- (home-page "https://libnice.freedesktop.org/")
- (license
- ;; This project is dual-licensed.
- (list
- license:lgpl2.1+
- license:mpl1.1)))))
+ (home-page "https://libnice.freedesktop.org/")
+ (license
+ ;; This project is dual-licensed.
+ (list
+ license:lgpl2.1+
+ license:mpl1.1))))
(define-public librecast
(package