summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-10 23:44:48 +0200
committerMarius Bakke <marius@gnu.org>2022-09-11 19:43:15 +0200
commit93376d5d9c2756fa09525fa62d4f6b64f4b3e736 (patch)
tree0d5ef405b940f6789fb9a31ff2c6e26f578380dc /gnu/packages/networking.scm
parent2500709e01cd376cf0db78e0805005a112343346 (diff)
gnu: Open vSwitch: Adjust tests for grep 3.8.
* gnu/packages/networking.scm (openvswitch)[arguments]: Add substitution for 'egrep'.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index f5f1f447cb..bde43bd912 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2763,6 +2763,11 @@ procedure calls (RPCs).")
(("#! /bin/sh")
(string-append "#! " /bin/sh))
+ ;; grep 3.8 emits a warning for 'egrep' which breaks
+ ;; expected output; adjust accordingly.
+ (("egrep")
+ "grep -E")
+
;; The tests use 'kill -0' to check whether a test has
;; completed, but it does not work in the build container
;; because zombies are not reaped automatically (PID 1 is