summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2016-04-07 12:59:35 +0200
committerJohn Darrington <jmd@gnu.org>2016-04-07 19:12:28 +0200
commitc791efde74a98a2226bd26335b40815cbf2894c9 (patch)
tree40dc330525b84d859f550e7c78c9e98c2699ab99 /gnu/packages/networking.scm
parentc5b5e275a7766e07c39eba213be143db882d5193 (diff)
gnu: Add macchanger.
* gnu/packages/networking.scm (macchanger): New variable.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index a4f431a0b1..306a3a0218 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2015 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2016 Raimon Grau <raimonster@gmail.com>
;;; Copyright © 2016 Tobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>
+;;; Copyright 2016 John Darrington <jmd@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -32,6 +33,26 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages compression))
+(define-public macchanger
+ (package
+ (name "macchanger")
+ (version "1.6.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/"
+ name "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1xsiivjjyhqcs6dyjcshrnxlgypvyfzacjz7gcjgl88xiw9lylri"))))
+ (build-system gnu-build-system)
+ (home-page "http://www.gnu.org/software/macchanger")
+ (synopsis "Display or change the MAC address of networking devices")
+ (description "GNU MAC Changer is a utility for viewing and changing MAC
+addresses of networking devices. New addresses may be set explicitly or
+randomly. They can include MAC addresses of the same or other hardware vendors
+or, more generally, MAC addresses of the same category of hardware.")
+ (license license:gpl2+)))
+
(define-public miredo
(package
(name "miredo")