summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-07-03 12:10:10 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-18 22:56:41 +0200
commit63a1783d3a0bdd4295117d8de5dbcfe6b04f6781 (patch)
tree1d2256c153024227dd2dbf28ceffa4d8cc643278 /gnu/packages/networking.scm
parentc42526e9473d6f78e029b6e3061938fb9d40f7e5 (diff)
gnu: Add rtmpdump.
* gnu/packages/networking.scm (rtmpdump): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 5158d9c1c7..b92ac4b018 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -135,6 +135,41 @@
#:use-module (gnu packages xml)
#:use-module (ice-9 match))
+(define-public rtmpdump
+ (package
+ (name "rtmpdump")
+ (version "2.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://rtmpdump.mplayerhq.hu/download/"
+ name "-" version ".tgz"))
+ (sha256
+ (base32 "0b2b49a57kpz9gi8dx1x3cs8b0gjx8x0c89x0q96kkl2knlvff7g"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; No tests
+ #:make-flags
+ (list
+ (string-append "prefix=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (inputs
+ `(("openssl" ,openssl-1.0)
+ ("zlib" ,zlib)))
+ (synopsis "Tools and library for handling RTMP streams")
+ (description "RTMPdump is a toolkit for RTMP streams. All forms of RTMP are
+supported, including rtmp://, rtmpt://, rtmpe://, rtmpte://, and rtmps://.")
+ (home-page "https://rtmpdump.mplayerhq.hu/")
+ (license
+ (list
+ ;; Library.
+ license:lgpl2.1+
+ ;; Others.
+ license:gpl2+))))
+
(define-public srt
(package
(name "srt")