summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-08-01 23:39:48 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-08-03 23:30:12 -0400
commit9f7dc7645173e49247da2bb1a0aeb3a04b101991 (patch)
tree4e1f800d63b05711f3b9b84e0a39374d1cfb8c3c /gnu/packages/networking.scm
parent5cba0f48053c036466ff8a61395673ca504e0f73 (diff)
gnu: opendht: Propagate gnutls.
Propagate gnutls as it's included by the opendht/crypto.h header file. * gnu/packages/networking.scm (opendht)[inputs]: Move gnutls... [propagated-inputs]: ...to here. Move argon2 to inputs.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 0a311ec64a..3a74c59ea4 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -26,7 +26,7 @@
;;; Copyright © 2018, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018, 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
-;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2019, 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2019 Vasile Dumitrascu <va511e@yahoo.com>
;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2019 Timotej Lazar <timotej.lazar@araneo.si>
@@ -2926,20 +2926,20 @@ and targeted primarily for asynchronous processing of HTTP-requests.")
;; Since 2.0, the gnu-build-system does not seem to work anymore, upstream bug?
(build-system cmake-build-system)
(inputs
- `(("gnutls" ,gnutls)
+ `(("argon2" ,argon2)
("nettle" ,nettle)
("readline" ,readline)
("jsoncpp" ,jsoncpp)
- ("openssl" ,openssl)
+ ("openssl" ,openssl) ;required for the DHT proxy
("fmt" ,fmt)))
(propagated-inputs
- `(("argon2" ,argon2) ; TODO: Needed for the pkg-config .pc file to work?
+ `(("gnutls" ,gnutls) ;included in opendht/crypto.h
("msgpack" ,msgpack))) ;included in several installed headers
(native-inputs
`(("autoconf" ,autoconf)
- ("pkg-config" ,pkg-config)
- ("restinio" ,restinio)
("automake" ,automake)
+ ("pkg-config" ,pkg-config)
+ ("restinio" ,restinio) ;headers only library
("libtool" ,libtool)
("cppunit" ,cppunit)))
(arguments