summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorPetter <petter@mykolab.ch>2017-05-02 16:57:52 +0200
committerLudovic Courtès <ludo@gnu.org>2017-05-02 23:41:14 +0200
commit2f3108ad036d5d59d0c8247703ba22adb57638e5 (patch)
tree185532b3425ea6e04f51d99ef8964e6ce07801ce /gnu/packages/networking.scm
parentdcb95c1fc936d74dfdf84b7e59eff66cb99c5a63 (diff)
gnu: Avoid circular dependencies by Perl license.
* guix/licenses.scm (perl-license): New variable. * gnu/packages/bioinformatics.scm: Change (package-license perl) to perl-license. * gnu/packages/compression.scm: Same. * gnu/packages/databases.scm: Same. * gnu/packages/gd.scm: Same. * gnu/packages/language.scm: Same. * gnu/packages/libevent.scm: Same. * gnu/packages/mail.scm: Same. * gnu/packages/messaging.scm: Same. * gnu/packages/ncurses.scm: Same. * gnu/packages/networking.scm: Same. * gnu/packages/photo.scm: Same. * gnu/packages/tcl.scm: Same. * gnu/packages/tex.scm: Same. * gnu/packages/tls.scm: Same. * gnu/packages/web.scm: Same. * gnu/packages/wm.scm: Same. * gnu/packages/xml.scm: Same. * gnu/packages/xorg.scm: Same. * gnu/packages/zip.scm: Same. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 3182443c19..ea01bb7cec 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -739,7 +739,7 @@ definitions and structure manipulators for Perl.")
"Programmable DNS resolver class for offline emulation of DNS")
(description "Net::DNS::Resolver::Programmable is a programmable DNS resolver for
offline emulation of DNS.")
- (license (package-license perl))))
+ (license license:perl-license)))
(define-public perl-netaddr-ip
(package
@@ -772,7 +772,7 @@ offline emulation of DNS.")
(synopsis
"Manages IPv4 and IPv6 addresses and subnets")
(description "NetAddr::IP manages IPv4 and IPv6 addresses and subsets.")
- (license (package-license perl))))
+ (license license:perl-license)))
(define-public perl-net-patricia
(package
@@ -846,7 +846,7 @@ offline emulation of DNS.")
"Look up location and network information by IP Address in Perl")
(description "The Perl module 'Geo::IP'. It looks up location and network
information by IP Address.")
- (license (package-license perl))))
+ (license license:perl-license)))
(define-public perl-io-socket-inet6
(package
@@ -876,7 +876,7 @@ information by IP Address.")
"Perl object interface for AF_INET/AF_INET6 domain sockets")
(description "IO::Socket::INET6 is an interface for AF_INET/AF_INET6 domain
sockets in Perl.")
- (license (package-license perl))))
+ (license license:perl-license)))
(define-public proxychains-ng
(package