summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2016-09-15 01:15:02 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2016-09-16 01:53:51 +0200
commit60880ac5560591318eabe9a233585e9c7d64f5d9 (patch)
tree35a1cd44ebb5d3537b1738cc907c99c323db4db1 /gnu/packages/networking.scm
parent71af71dc74906130e3dd7ed2b5bd27e5d4699b52 (diff)
gnu: iodine: Use net-tools' ifconfig with an absolute path.
* gnu/packages/networking.scm (iodine)[arguments]: Add fix-ifconfig-path phase. [inputs]: Add net-tools.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index c4edbc319a..47aa2b9cc9 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -391,8 +391,14 @@ and min/max network usage.")
'(#:phases
(modify-phases %standard-phases
(delete 'configure)
+ (add-before 'build 'fix-ifconfig-path
+ ;; This package works only with the net-tools version of ifconfig.
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/tun.c"
+ (("PATH=[^ ]* ")
+ (string-append (assoc-ref inputs "net-tools") "/sbin/")))))
(add-before 'check 'delete-failing-tests
- ;; Avoid https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=802105
+ ;; Avoid https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=802105.
(lambda _
(substitute* "tests/common.c"
(("tcase_add_test\\(tc, \
@@ -401,7 +407,8 @@ test_parse_format_ipv(4(|_listen_all|_mapped_ipv6)|6)\\);")
#:make-flags (list "CC=gcc"
(string-append "prefix=" (assoc-ref %outputs "out")))
#:test-target "test"))
- (inputs `(("zlib" ,zlib)))
+ (inputs `(("net-tools" ,net-tools)
+ ("zlib" ,zlib)))
(native-inputs `(("check" ,check)
("pkg-config" ,pkg-config)))
(home-page "http://code.kryo.se/iodine/")