summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-09-15 15:01:14 +0000
committerLeo Famulari <leo@famulari.name>2016-09-23 19:18:10 -0400
commit93666cf7837edfe85c7c0960252d6ad9b4962717 (patch)
tree6767fe480b21d79ebdffd6f60c93f87eba0107c0 /gnu/packages/networking.scm
parent03ddad84bae4c862c728f617ff70734df709bf63 (diff)
gnu: Add enet.
* gnu/packages/networking.scm (enet): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 6010e86ac7..ba8d08227c 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -831,3 +831,29 @@ in dynamically linked programs and redirects them through one or more SOCKS or
HTTP proxies.")
(home-page "https://github.com/rofl0r/proxychains-ng")
(license license:gpl2+)))
+
+(define-public enet
+ (package
+ (name "enet")
+ (version "1.3.13")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://enet.bespin.org/download/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0p53mnmjbm56wizwraznynx13fcibcxiqny110dp6a5a3w174q73"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (synopsis
+ "Network communication layer on top of UDP")
+ (description
+ "ENet's purpose is to provide a relatively thin, simple and robust network
+communication layer on top of UDP. The primary feature it provides is optional
+reliable, in-order delivery of packets. ENet omits certain higher level
+networking features such as authentication, server discovery, encryption, or
+other similar tasks that are particularly application specific so that the
+library remains flexible, portable, and easily embeddable.")
+ (home-page "http://enet.bespin.org")
+ (license license:expat)))