summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2016-07-28 23:38:28 +0200
committerLeo Famulari <leo@famulari.name>2016-08-08 22:36:38 -0400
commite741c4e42434d19d8d0bd37fec371042598efbd9 (patch)
treed2b7bf1e761a70ee2802713712086c72824cc4fc /gnu/packages/networking.scm
parentb09a8b6f637a17579976b80417c7d2dad8a05e61 (diff)
gnu: Add perl-geo-ip.
* gnu/packages/networking.scm (perl-geo-ip): Add variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index bb46cdd7f5..31379411d5 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -581,3 +581,27 @@ offline emulation of DNS.")
"Perl extension for merging IPv4 or IPv6 CIDR addresses")
(description "Net::CIDR::Lite merges IPv4 or IPv6 CIDR addresses.")
(license license:gpl1+)))
+
+;; TODO: Use the geolite-mirror-simple.pl script from the example
+;; directory to stay current with the databases. How?
+(define-public perl-geo-ip
+ (package
+ (name "perl-geo-ip")
+ (version "1.50")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/M/MA/MAXMIND/Geo-IP-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0ar69lrm26rp6sqxjf0p6cvjfprjx8gkxx11r399lvh99rqfl7zr"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Geo-IP")
+ (synopsis
+ "Look up location and network information by IP Address in Perl")
+ (description "The Perl module 'Geo::IP'. It looks up location and network
+information by IP Address.")
+ (license (package-license perl))))