summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2023-07-21 20:14:30 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-08-13 15:24:04 +0800
commit1ff1b92142c48ac5a5c71eea47dd20370b3aa773 (patch)
tree8c603fc2e245af7673e4274c99d5f5ee2e5c00e6 /gnu/packages/networking.scm
parent6b7fb36d30ba1423facfd844821735c475808d02 (diff)
gnu: libcamera: Split off gst and tools outputs.
* gnu/packages/networking.scm (libcamera)[outputs]: Add gst and tools. [arguments]: Pass "-Dbindir" to configure-flags. Adjust 'move-doc phase to 'move-doc-and-gst.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm14
1 files changed, 10 insertions, 4 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 2f2d16b52a..5a027b5af7 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -363,25 +363,31 @@ them in order to efficiently transfer a minimal amount of data.")
(sha256
(base32 "06dj3dpfbayj61015n5kffin2g3hyys11ra0px2g4hmrznvdkhc9"))))
(build-system meson-build-system)
- (outputs '("out" "doc"))
+ (outputs '("out" "doc" "gst" "tools"))
(arguments
`(#:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
#:configure-flags
(list
+ (string-append "-Dbindir=" (assoc-ref %outputs "tools") "/bin")
"-Dtest=true"
"-Dv4l2=true"
;; XXX: Requires bundled pybind11.
"-Dpycamera=disabled")
#:phases
(modify-phases %standard-phases
- (add-after 'install 'move-doc
+ (add-after 'install 'move-doc-and-gst
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
- (doc (assoc-ref outputs "doc")))
+ (doc (assoc-ref outputs "doc"))
+ (gst (assoc-ref outputs "gst")))
(mkdir-p (string-append doc "/share"))
(rename-file
(string-append out "/share/doc")
- (string-append doc "/share/doc"))))))))
+ (string-append doc "/share/doc"))
+ (mkdir-p (string-append gst "/lib"))
+ (rename-file
+ (string-append out "/lib/gstreamer-1.0")
+ (string-append gst "/lib/gstreamer-1.0"))))))))
(native-inputs
(list googletest
graphviz ;for 'dot'