summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-07 23:32:43 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-08 09:36:26 -0500
commit57c8ba22cf2fbab742730b3df7531f161af08fcb (patch)
tree1ea381be68f55f309121d884e3918af09a0da9f5 /gnu/packages/networking.scm
parente0d89c37355bc09f6e561917a41ddd971f205cee (diff)
gnu: opendht: Add a "python" output.
This reduces the size of the main output from 286.1 MiB to 216.6 MiB. * gnu/packages/networking.scm (opendht) [outputs]: Add "python". [phases]: Adjust Python prefix of the fix-python-installation-prefix phase. [inputs]: Add python, used to wrap the tools.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index b33192d8cb..75ffe00b44 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -3719,7 +3719,7 @@ and targeted primarily for asynchronous processing of HTTP-requests.")
(sha256
(base32
"1kcc9vmi4swvahq2gikflgba9xfmix80dr9wa3v6xcj1ba2fjd6s"))))
- (outputs '("out" "tools" "debug"))
+ (outputs '("out" "python" "tools" "debug"))
(build-system gnu-build-system)
(arguments
(list
@@ -3754,7 +3754,7 @@ and targeted primarily for asynchronous processing of HTTP-requests.")
(substitute* "python/Makefile.am"
(("--root=\\$\\(DESTDIR)/")
(string-append "--root=/ --single-version-externally-managed "
- "--prefix=" #$output)))))
+ "--prefix=" #$output:python)))))
(add-after 'unpack 'specify-runpath-for-python-module
(lambda _
(substitute* "python/setup.py.in"
@@ -3792,7 +3792,8 @@ and targeted primarily for asynchronous processing of HTTP-requests.")
gnutls
jsoncpp
nettle
- openssl)) ;required for the DHT proxy
+ openssl ;required for the DHT proxy
+ python))
(native-inputs
(list autoconf
automake