summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:03 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:01 +0200
commita18d57d1f8ae6a39941a84998bddaf361053aa07 (patch)
treea3ba8f81c75553baa2be643652fddb10a2e7d074 /gnu/packages/networking.scm
parent7fcd97b77979a5083ed64e6fad137c1ad5716e4d (diff)
gnu: spiped: Use G-expressions.
* gnu/packages/networking.scm (spiped)[arguments]: Rewrite as G-expressions.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm44
1 files changed, 21 insertions, 23 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index b885e73dcd..a490fafb5c 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2985,30 +2985,28 @@ enabled due to license conflicts between the BSD advertising clause and the GPL.
"0rs5403bp48wyy2x0f3hk0f75ds1qn03sgyli2c7y7fi29ynim05"))))
(build-system gnu-build-system)
(arguments
- `(#:test-target "test"
- #:make-flags (let* ((out (assoc-ref %outputs "out"))
- (bindir (string-append out "/bin"))
- (man1dir (string-append out "/share/man/man1")))
- (list ,(string-append "CC=" (cc-for-target)) ; It tries to invoke `c99`.
- (string-append "BINDIR=" bindir)
- (string-append "MAN1DIR=" man1dir)))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-command-invocations
- (lambda _
- (substitute* '("Makefile"
- "libcperciva/cpusupport/Build/cpusupport.sh"
- "libcperciva/POSIX/posix-cflags.sh"
- "libcperciva/POSIX/posix-l.sh")
- (("command -p") ""))))
- (delete 'configure) ; No ./configure script.
- (add-after 'install 'install-more-docs
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref %outputs "out"))
- (misc (string-append out "/share/doc/spiped")))
- (install-file "DESIGN.md" misc)))))))
+ (list
+ #:test-target "test"
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "BINDIR=" #$output "/bin")
+ (string-append "MAN1DIR=" #$output "/share/man/man1"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-command-invocations
+ (lambda _
+ (substitute* '("Makefile"
+ "libcperciva/cpusupport/Build/cpusupport.sh"
+ "libcperciva/POSIX/posix-cflags.sh"
+ "libcperciva/POSIX/posix-l.sh")
+ (("command -p") ""))))
+ (delete 'configure) ; no ./configure script
+ (add-after 'install 'install-more-docs
+ (lambda _
+ (install-file "DESIGN.md"
+ (string-append #$output "/share/doc/spiped")))))))
(native-inputs
- (list procps)) ; `ps` is used by the test suite.
+ (list procps)) ; `ps` is used by the test suite
(inputs
(list openssl))
(home-page "https://www.tarsnap.com/spiped.html")