summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2023-02-09 20:50:10 +0100
committerAndreas Enge <andreas@enge.fr>2023-02-09 21:27:06 +0100
commitbf667efe910f740282aee1ebe1891b452224d31e (patch)
tree4b10da2dfdb7415b174eb87e0ed958de72bad4de /gnu/packages/networking.scm
parent3584cff93d5fd78faf9e41db629351bf570a63f5 (diff)
gnu: Add perl-net-bonjour.
* gnu/packages/networking.scm (perl-net-bonjour): New variable.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 75ffe00b44..a9ea07d7b1 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -55,6 +55,7 @@
;;; Copyright © 2022 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;; Copyright © 2022 Reza Alizadeh Majd <r.majd@pantherx.org>
;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2023 Andreas Enge <andreas@enge.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2304,6 +2305,28 @@ private (reserved).")
(description "Net::DNS is the Perl Interface to the Domain Name System.")
(license license:x11)))
+(define-public perl-net-bonjour
+ (package
+ (name "perl-net-bonjour")
+ (version "0.96")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/C/CH/CHLIGE/Net-Bonjour-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "15qzkfk0isn6c4js3ih95k3dylq6scijp863s0485c00n8x1z2n3"))))
+ (build-system perl-build-system)
+ (propagated-inputs (list perl-net-dns))
+ (home-page "https://metacpan.org/release/Net-Bonjour")
+ (synopsis "Module for DNS service discovery (Apple's Bonjour)")
+ (description "Net::Bonjour is a set of modules that allow one to
+discover local services via multicast DNS (mDNS) or enterprise services
+via traditional DNS. This method of service discovery has been branded
+as Bonjour by Apple Computer.")
+ (license license:perl-license)))
+
(define-public perl-socket6
(package
(name "perl-socket6")