summaryrefslogtreecommitdiff
path: root/gnu/packages/node-xyz.scm
diff options
context:
space:
mode:
authorRikard Nordgren <hrn@posteo.net>2023-12-06 19:11:08 +0000
committerLudovic Courtès <ludo@gnu.org>2023-12-22 17:47:16 +0100
commit76ed5ec9f72b0f6a9b677214ce4e89fced07b79c (patch)
treeb829920cecaf47039d70ea5fa7deb2d8593f78ba /gnu/packages/node-xyz.scm
parentcd0b20582a043027ec80588296744fabd4c9797f (diff)
gnu: Add node-normalize-path.
* gnu/packages/node-xyz.scm (node-normalize-path): New variable. Change-Id: I9afbede1f16ed1157fed95d3925b97945a73c91b Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/node-xyz.scm')
-rw-r--r--gnu/packages/node-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 6c16417309..9eb8595add 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -347,6 +347,35 @@ random number generator.")
Javascript.")
(license license:expat)))
+(define-public node-normalize-path
+ (package
+ (name "node-normalize-path")
+ (version "3.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jonschlinkert/normalize-path")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1l079szbgw2b9i5zx6zbwvxiivssa55a4pwfy4m7n6rdkcmsxf7f"))))
+ (build-system node-build-system)
+ (arguments
+ '(#:tests? #f
+ #:phases (modify-phases %standard-phases
+ (add-after 'patch-dependencies 'delete-dependencies
+ (lambda _
+ (delete-dependencies '("gulp-format-md" "mocha")))))))
+ (native-inputs (list node-minimist))
+ (home-page "https://github.com/jonschlinkert/normalize-path")
+ (synopsis "Normalize slashes in a file path")
+ (description
+ "Normalize slashes in a file path to be POSIX/Unix-like forward slashes.
+Can also condense repeated slashes to a single slash and remove trailing
+slashes, unless disabled.")
+ (license license:expat)))
+
(define-public node-oop
;; No releases, last commit was February 2013.
(let ((commit "f9d87cda0958886955c14a0a716e57021ed295dc")