summaryrefslogtreecommitdiff
path: root/gnu/packages/node-xyz.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-02-04 13:40:23 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-18 12:34:47 +0000
commit614e615f5a050860f14e5357502af85f944056e0 (patch)
tree8c1fa01c0020f2e11f31ba956c402983c53a1ee9 /gnu/packages/node-xyz.scm
parent8a87e9e5d2250449c54fb17bbe66939176be37af (diff)
gnu: node-file-uri-to-path: Move package in alphabetical order.
* gnu/packages/node-xyz.scm (node-file-uri-to-path): Move package in alphabetical order. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/node-xyz.scm')
-rw-r--r--gnu/packages/node-xyz.scm108
1 files changed, 54 insertions, 54 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index dcda27e411..1afbf6deac 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -359,6 +359,60 @@ multiple node.js files, while providing useful information about output and exit
codes.")
(license license:expat)))
+(define-public node-file-uri-to-path
+ (package
+ (name "node-file-uri-to-path")
+ (version "2.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/TooTallNate/file-uri-to-path")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "08l779az44czm12xdhgcrnzpqw34s59hbrlfphs7g9y2k26drqav"))))
+ (native-inputs
+ (list esbuild))
+ (build-system node-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'patch-dependencies 'delete-dependencies
+ (lambda args
+ (delete-dependencies `("@types/mocha"
+ "@types/node"
+ "@typescript-eslint/eslint-plugin"
+ "@typescript-eslint/parser"
+ "cpy-cli"
+ "eslint"
+ "eslint-config-airbnb"
+ "eslint-config-prettier"
+ "eslint-import-resolver-typescript"
+ "eslint-plugin-import"
+ "eslint-plugin-jsx-a11y"
+ "eslint-plugin-react"
+ "mocha"
+ "rimraf"
+ "typescript"))))
+ (replace 'build
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ (copy-recursively "src" "dist")
+ (invoke (search-input-file (or native-inputs inputs)
+ "/bin/esbuild")
+ "dist/index.ts"
+ "--outfile=dist/src/index.js"
+ "--format=cjs"
+ "--sourcemap"
+ "--platform=node"))))
+ #:tests? #f))
+ (home-page "https://github.com/TooTallNate/file-uri-to-path")
+ (synopsis "Convert a @code{file:} URI to a file path")
+ (description "This package provides a function to convert a @code{file:}
+URI to a file path. It accepts a @code{file:} URI and returns a file path
+suitable for use with the @code{fs} module functions.")
+ (license license:expat)))
+
(define-public node-global-gradle-clean
(package
(name "node-global-gradle-clean")
@@ -1229,60 +1283,6 @@ function with browser support.")
particular cross-platform spellings of the PATH environment variable key.")
(license license:expat)))
-(define-public node-file-uri-to-path
- (package
- (name "node-file-uri-to-path")
- (version "2.0.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/TooTallNate/file-uri-to-path")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "08l779az44czm12xdhgcrnzpqw34s59hbrlfphs7g9y2k26drqav"))))
- (native-inputs
- (list esbuild))
- (build-system node-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'patch-dependencies 'delete-dependencies
- (lambda args
- (delete-dependencies `("@types/mocha"
- "@types/node"
- "@typescript-eslint/eslint-plugin"
- "@typescript-eslint/parser"
- "cpy-cli"
- "eslint"
- "eslint-config-airbnb"
- "eslint-config-prettier"
- "eslint-import-resolver-typescript"
- "eslint-plugin-import"
- "eslint-plugin-jsx-a11y"
- "eslint-plugin-react"
- "mocha"
- "rimraf"
- "typescript"))))
- (replace 'build
- (lambda* (#:key inputs native-inputs #:allow-other-keys)
- (copy-recursively "src" "dist")
- (invoke (search-input-file (or native-inputs inputs)
- "/bin/esbuild")
- "dist/index.ts"
- "--outfile=dist/src/index.js"
- "--format=cjs"
- "--sourcemap"
- "--platform=node"))))
- #:tests? #f))
- (home-page "https://github.com/TooTallNate/file-uri-to-path")
- (synopsis "Convert a @code{file:} URI to a file path")
- (description "This package provides a function to convert a @code{file:}
-URI to a file path. It accepts a @code{file:} URI and returns a file path
-suitable for use with the @code{fs} module functions.")
- (license license:expat)))
-
(define-public node-segfault-handler
(package
(name "node-segfault-handler")