summaryrefslogtreecommitdiff
path: root/gnu/packages/notcurses.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-04 12:03:24 +0200
committerMarius Bakke <marius@gnu.org>2022-08-04 12:30:13 +0200
commit243bcbb8a2ede8a092f42a4d90ec6efdce7f28d5 (patch)
tree6411d74eadceafa1fbcc780b8b061fdd3c9c2927 /gnu/packages/notcurses.scm
parentd0f25610d90753f336db11f09fd8e87d0d2c0121 (diff)
gnu: notcurses: Adjust indentation.
* gnu/packages/notcurses.scm (notcurses): Re-indent.
Diffstat (limited to 'gnu/packages/notcurses.scm')
-rw-r--r--gnu/packages/notcurses.scm90
1 files changed, 45 insertions, 45 deletions
diff --git a/gnu/packages/notcurses.scm b/gnu/packages/notcurses.scm
index 5bb8a24edd..bb0086d4b3 100644
--- a/gnu/packages/notcurses.scm
+++ b/gnu/packages/notcurses.scm
@@ -34,49 +34,49 @@
(define-public notcurses
(package
- (name "notcurses")
- (version "3.0.8")
- (source
- (origin
- (method url-fetch)
- ;; Note: the upstream git repository contains non-free media (see the
- ;; documentation for DFSG_BUILD; but the project provides a sanitized
- ;; tarball for distributions. If switching to a git source, we need
- ;; to find a way to elide the non-free demos with a source 'snippet'.
- (uri (string-append "https://github.com/dankamongmen/notcurses/releases"
- "/download/v" version "/notcurses_" version
- "+dfsg.1.orig.tar.xz"))
- (file-name (string-append name "-" version ".tar.xz"))
- (sha256
- (base32 "1nz32nqh7fn4i06hvl8ndkm0z4g08a6wzhilvv8ggx2hc5axsz89"))))
- (build-system cmake-build-system)
- (arguments
- `(#:make-flags
- (list (string-append "CC=" ,(cc-for-target)))
- ;; These flags are documented in 'INSTALL.md' in the source distribution.
- #:configure-flags
- '(;; Do not build "coverage"
- "-DUSE_COVERAGE=off"
- ;; Do not build HTML documentation
- "-DUSE_DOXYGEN=off"
- ;; Don't include mouse support
- "-DUSE_GPM=off"
- ;; Use FFmpeg for multimedia support
- "-DUSE_MULTIMEDIA=ffmpeg"
- ;; Follow the Debian Free Software Guidelines, omitting nonfree content.
- "-DDFSG_BUILD=ON")))
- (native-inputs
- (list pkg-config
- pandoc
- doctest))
- (inputs
- (list ffmpeg
- libdeflate
- libunistring
- ncurses
- zlib))
- (synopsis "Textual user interfaces")
- (description "Notcurses is a library for building complex textual user
+ (name "notcurses")
+ (version "3.0.8")
+ (source
+ (origin
+ (method url-fetch)
+ ;; Note: the upstream git repository contains non-free media (see the
+ ;; documentation for DFSG_BUILD; but the project provides a sanitized
+ ;; tarball for distributions. If switching to a git source, we need
+ ;; to find a way to elide the non-free demos with a source 'snippet'.
+ (uri (string-append "https://github.com/dankamongmen/notcurses/releases"
+ "/download/v" version "/notcurses_" version
+ "+dfsg.1.orig.tar.xz"))
+ (file-name (string-append name "-" version ".tar.xz"))
+ (sha256
+ (base32 "1nz32nqh7fn4i06hvl8ndkm0z4g08a6wzhilvv8ggx2hc5axsz89"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:make-flags
+ (list (string-append "CC=" ,(cc-for-target)))
+ ;; These flags are documented in 'INSTALL.md' in the source distribution.
+ #:configure-flags
+ '( ;; Do not build "coverage"
+ "-DUSE_COVERAGE=off"
+ ;; Do not build HTML documentation
+ "-DUSE_DOXYGEN=off"
+ ;; Don't include mouse support
+ "-DUSE_GPM=off"
+ ;; Use FFmpeg for multimedia support
+ "-DUSE_MULTIMEDIA=ffmpeg"
+ ;; Follow the Debian Free Software Guidelines, omitting nonfree content.
+ "-DDFSG_BUILD=ON")))
+ (native-inputs
+ (list pkg-config
+ pandoc
+ doctest))
+ (inputs
+ (list ffmpeg
+ libdeflate
+ libunistring
+ ncurses
+ zlib))
+ (synopsis "Textual user interfaces")
+ (description "Notcurses is a library for building complex textual user
interfaces on modern terminals.")
- (home-page "https://notcurses.com")
- (license license:asl2.0)))
+ (home-page "https://notcurses.com")
+ (license license:asl2.0)))