summaryrefslogtreecommitdiff
path: root/gnu/packages/nss.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-10-01 16:21:04 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-10-02 11:00:02 +0000
commit385ba2f369e8fd65e5387185c36127cef7a78488 (patch)
tree225de38fe70024fdd17eef046e5e29e18e712d31 /gnu/packages/nss.scm
parentfae2fcdbc9000405e01e6cdf635c10835f697045 (diff)
gnu: nspr: Use mozilla-build-system.
* gnu/packages/nss.scm (nspr)[build-system]: Adjust it. (nspr)[arguments]<#:configure-flags>: Remove now superfluous --target and --host. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/nss.scm')
-rw-r--r--gnu/packages/nss.scm14
1 files changed, 3 insertions, 11 deletions
diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
index 381756e387..6196ad692d 100644
--- a/gnu/packages/nss.scm
+++ b/gnu/packages/nss.scm
@@ -29,6 +29,7 @@
#:use-module (guix gexp)
#:use-module (guix download)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system mozilla)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages)
#:use-module (gnu packages bash)
@@ -49,7 +50,7 @@
(sha256
(base32
"1j5b2m8cjlhnnv8sq34587avaagkqvh521w4f95miwgvsn3xlaap"))))
- (build-system gnu-build-system)
+ (build-system mozilla-build-system)
(inputs
;; TODO(core-updates): Make these inputs unconditional.
;; For 'compile-et.pl' and 'nspr-config'.
@@ -72,16 +73,7 @@
(list "--disable-static"
"--enable-64bit"
(string-append "LDFLAGS=-Wl,-rpath="
- (assoc-ref %outputs "out") "/lib")
- ;; Mozilla deviates from Autotools conventions
- ;; due to historical reasons. Adjust to Mozilla conventions,
- ;; otherwise the Makefile will try to use TARGET-gcc
- ;; as a ‘native’ compiler.
- ,@(if (%current-target-system)
- `(,(string-append "--host="
- (nix-system->gnu-triplet (%current-system)))
- ,(string-append "--target=" (%current-target-system)))
- '()))
+ (assoc-ref %outputs "out") "/lib"))
;; Use fixed timestamps for reproducibility.
#:make-flags '("SH_DATE='1970-01-01 00:00:01'"
;; This is epoch 1 in microseconds.