summaryrefslogtreecommitdiff
path: root/gnu/packages/ntp.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:01 +0200
commit75184011c7dec0ec217d7cde9592b12488e77578 (patch)
tree1be24f22b6613b2e46c3c28e7fdce7363f9c85e3 /gnu/packages/ntp.scm
parent9a84da4418ac7658c5a22aee92aac63b44806145 (diff)
gnu: ntp: Use G-expressions.
* gnu/packages/ntp.scm (ntp)[arguments]: Rewrite as G-expressions.
Diffstat (limited to 'gnu/packages/ntp.scm')
-rw-r--r--gnu/packages/ntp.scm21
1 files changed, 12 insertions, 9 deletions
diff --git a/gnu/packages/ntp.scm b/gnu/packages/ntp.scm
index f12bfd469b..1a72efbc79 100644
--- a/gnu/packages/ntp.scm
+++ b/gnu/packages/ntp.scm
@@ -37,6 +37,7 @@
#:use-module (gnu packages tls)
#:use-module (guix build-system gnu)
#:use-module (guix download)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module ((guix licenses) #:prefix l:)
#:use-module (guix packages)
@@ -143,15 +144,17 @@ time-stamping or reference clock, sub-microsecond accuracy is possible.")
(list libcap)
'())))
(arguments
- `(;; Pass "--with-yielding-select=yes" so that 'configure' knows whether
- ;; 'select' yields when using pthreads in a cross-compilation context.
- #:configure-flags (list "--with-yielding-select=yes")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'disable-network-test
- (lambda _
- (substitute* "tests/libntp/Makefile.in"
- (("test-decodenetnum\\$\\(EXEEXT\\) ") "")))))))
+ (list
+ ;; Pass "--with-yielding-select=yes" so that 'configure' knows whether
+ ;; 'select' yields when using pthreads in a cross-compilation context.
+ #:configure-flags
+ #~(list "--with-yielding-select=yes")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-network-test
+ (lambda _
+ (substitute* "tests/libntp/Makefile.in"
+ (("test-decodenetnum\\$\\(EXEEXT\\) ") "")))))))
(build-system gnu-build-system)
(synopsis "Real time clock synchronization system")
(description "NTP is a system designed to synchronize the clocks of