summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <jean@foundationdevices.com>2023-05-21 13:34:16 +0200
committerLudovic Courtès <ludo@gnu.org>2023-06-02 16:27:39 +0200
commit5461ff1e54f183e73fa642d25a2fe5d181df642f (patch)
tree1153b35650d1f75a2e65ba698431412117a23b04 /gnu/packages/ocaml.scm
parent4017fae4e0b865c9e3ef0223ec226bef486ec278 (diff)
gnu: Add ocaml-pyml.
* gnu/packages/ocaml.ml (ocaml-pyml): New variable. Signed-off-by: Jean-Pierre De Jesus DIAZ <jean@foundationdevices.com> Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 0656abb610..ab0aa0574a 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2735,6 +2735,40 @@ parameter @code{ncores}.")
(license:fsdg-compatible "file://LICENSE"
"See LICENSE file for details")))))
+(define-public ocaml-pyml
+ ;; NOTE: Using commit from master branch as 20220905 does not support
+ ;; Python 3.10.
+ (let ((revision "0")
+ (commit "e33f4c49cc97e7bc6f8e5faaa64cce994470642e"))
+ (package
+ (name "ocaml-pyml")
+ (version (git-version "20220905" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/thierry-martinez/pyml")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1v421i5cvj8mbgrg5cs78bz1yzdprm9r5r41niiy20d3j7j8jx9k"))))
+ (build-system dune-build-system)
+ (propagated-inputs
+ (list ocaml-stdcompat
+ python
+ python-numpy))
+ (home-page "https://github.com/thierry-martinez/pyml")
+ (synopsis "Python bindings for OCaml")
+ (description "Library that allows OCaml programs to interact with Python
+modules and objects. The library also provides low-level bindings to the
+Python C API.
+
+This library is an alternative to @code{pycaml} which is no longer
+maintained. The @code{Pycaml} module provides a signature close to
+@code{pycaml}, to ease migration of code to this library.")
+ (license license:bsd-2))))
+
(define-public ocaml-react
(package
(name "ocaml-react")