summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-01 19:11:30 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:43 +0200
commitfc91998274bd747668d1497aa799c8c1ec523738 (patch)
tree4e396b25f2290d0023db1f6cb127e37aee3b47f4 /gnu/packages/ocaml.scm
parent97a59bbef984da312c3565ab7d01ad4304950590 (diff)
gnu: ocaml-bibtex2html: Improve package style.
* gnu/packages/ocaml.scm (ocaml-bibtex2html)[origin]<uri>: Re-use version. [arguments]: Use G-expressions. Remove trailing #T from phases. [native-inputs]: Remove labels.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm36
1 files changed, 20 insertions, 16 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f5938d2f40..e919c40973 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -10239,28 +10239,32 @@ SHA384, SHA512, Blake2b, Blake2s and RIPEMD160.")
(name "ocaml-bibtex2html")
(version "1.99")
(source
- (origin
- (method url-fetch)
- (uri "https://www.lri.fr/~filliatr/ftp/bibtex2html/bibtex2html-1.99.tar.gz")
- (sha256 (base32 "07gzrs4lfrkvbn48cgn2gn6c7cx3jsanakkrb2irj0gmjzfxl96j"))))
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.lri.fr/~filliatr/ftp/bibtex2html/"
+ "bibtex2html-" version ".tar.gz"))
+ (sha256
+ (base32
+ "07gzrs4lfrkvbn48cgn2gn6c7cx3jsanakkrb2irj0gmjzfxl96j"))))
(build-system ocaml-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
(add-after 'unpack 'patch-/bin/sh
(lambda _
(substitute* "configure" (("/bin/sh") (which "bash")))
- (setenv "HOME" (getcwd)) ;; mktexfmt needs writable home directory
- #t)))))
+ ;; mktexfmt needs writable home directory.
+ (setenv "HOME" (getcwd)))))))
(native-inputs
- `(("which" ,which)
- ("texlive" ,(texlive-updmap.cfg
- (list texlive-bibtex
- texlive-hyperref
- texlive-infwarerr
- texlive-kvoptions
- texlive-pdftexcmds
- texlive-preprint)))))
+ (list (texlive-updmap.cfg
+ (list texlive-bibtex
+ texlive-hyperref
+ texlive-infwarerr
+ texlive-kvoptions
+ texlive-pdftexcmds
+ texlive-preprint))
+ which))
(propagated-inputs
(list hevea))
(home-page "https://www.lri.fr/~filliatr/bibtex2html/")