summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorGarek Dyszel <garekdyszel@disroot.org>2022-09-07 14:33:00 -0400
committerJulien Lepiller <julien@lepiller.eu>2022-09-24 20:24:37 +0200
commit8371ad64083970f68c8e1dd5f04b1f10d9cf029d (patch)
treec04a27dec3433b7b1374a8bc792721b9aeda8c01 /gnu/packages/ocaml.scm
parentfc07082fe3d750c85282c4aa57d01a36ebe9296b (diff)
gnu: Add ocaml-ansiterminal.
* gnu/packages/ocaml.scm (ocaml-ansiterminal): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index a477ded43d..01b090b7c0 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -26,6 +26,7 @@
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2022 Garek Dyszel <garekdyszel@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4473,6 +4474,35 @@ sensitive completion, colors, and more.")
("ocaml-zed" ,ocaml-zed)))
(properties '()))))
+(define-public ocaml-ansiterminal
+ (package
+ (name "ocaml-ansiterminal")
+ (version "0.8.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Chris00/ANSITerminal")
+ (commit version)
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "052qnc23vmxp90yympjz9q6lhqw98gs1yvb3r15kcbi1j678l51h"))))
+ (build-system dune-build-system)
+ (arguments
+ `(#:test-target "tests"))
+ (home-page "https://github.com/Chris00/ANSITerminal")
+ (synopsis
+ "Basic control of ANSI compliant terminals and the windows shell")
+ (description
+ "ANSITerminal is a module allowing to use the colors and cursor
+movements on ANSI terminals.")
+ ;; Variant of the LGPL3+ which permits
+ ;; static and dynamic linking when producing binary files.
+ ;; In other words, it allows one to link to the library
+ ;; when compiling nonfree software.
+ (license (license:non-copyleft "LICENSE.md"))))
+
(define-public ocaml-ptmap
(package
(name "ocaml-ptmap")