summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-12-25 10:56:16 +0100
committerJulien Lepiller <julien@lepiller.eu>2023-12-30 22:10:11 +0100
commit553c25da8240e035d9853f167c79177385a9a4ca (patch)
tree7596b98b95a5175d3913cbc42ea0575332cb2f34 /gnu/packages/ocaml.scm
parent44e4726a5eff2c0c70561e196f3e74f1a5a91789 (diff)
gnu: Remove ocaml4.07-ppx-typerep-conv.
* gnu/packages/ocaml.scm (ocaml4.07-ppx-typerep-conv): Remove variable. (ocaml-ppx-typerep-conv)[properties]: Remove variant. Change-Id: Iacd645286f2b1819d94c44fb6545382d755906bd
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm22
1 files changed, 1 insertions, 21 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index c96a2a24cd..b6590509af 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7622,33 +7622,13 @@ packages.")
(base32 "1q1lzykpm83ra4l5jh4rfddhd3c96kx4s4rvx0w4b51z1qk56zam"))))
(build-system dune-build-system)
(propagated-inputs (list ocaml-base ocaml-typerep ocaml-ppxlib))
- (properties `((upstream-name . "ppx_typerep_conv")
- (ocaml4.07-variant . ,(delay ocaml4.07-ppx-typerep-conv))))
+ (properties `((upstream-name . "ppx_typerep_conv")))
(home-page "https://github.com/janestreet/ppx_typerep_conv")
(synopsis "Generation of runtime types from type declarations")
(description "This package can automatically generate runtime types
from type definitions.")
(license license:expat)))
-(define-public ocaml4.07-ppx-typerep-conv
- (package-with-ocaml4.07
- (package
- (inherit ocaml-ppx-typerep-conv)
- (version "0.11.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/janestreet/ppx_typerep_conv")
- (commit (string-append "v" version))))
- (file-name (git-file-name "ocaml4.07-ppx-typerep-conv" version))
- (sha256
- (base32
- "0a13dpfrrg0rsm8qni1bh7pqcda30l70z8r6yzi5a64bmwk7g5ah"))))
- (properties '())
- (propagated-inputs
- (list ocaml-base ocaml-typerep ocaml-migrate-parsetree ocaml-ppxlib))
- (license license:asl2.0))))
-
(define-public ocaml-ppx-string
(package
(name "ocaml-ppx-string")