summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-12-25 11:11:41 +0100
committerJulien Lepiller <julien@lepiller.eu>2023-12-30 22:11:32 +0100
commitab51be3aba72f857363a2fca3358ef74a1e87d1f (patch)
treeebbc3c36afd257047f6b86830e0074583f3e63d4 /gnu/packages/ocaml.scm
parent952963aba8db1a052fd86920d95be16ad56de187 (diff)
gnu: Remove ocaml4.07-ppx-here.
* gnu/packages/ocaml.scm (ocaml4.07-ppx-here): Remove variable. (ocaml-ppx-here)[properties]: Remove variant. Change-Id: I7b54d003c6bf988eb93d6a2345296d11add14f6d
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm13
1 files changed, 1 insertions, 12 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 34bb570dd4..c31176720b 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6924,24 +6924,13 @@ many values).")
`(#:tests? #f))
(propagated-inputs
(list ocaml-base ocaml-migrate-parsetree ocaml-ppxlib))
- (properties `((upstream-name . "ppx_here")
- (ocaml4.07-variant . ,(delay ocaml4.07-ppx-here))))
+ (properties `((upstream-name . "ppx_here")))
(home-page "https://github.com/janestreet/ppx_here")
(synopsis "Expands [%here] into its location")
(description
"Part of the Jane Street's PPX rewriters collection.")
(license license:asl2.0)))
-(define-public ocaml4.07-ppx-here
- (package-with-ocaml4.07
- (package
- (inherit ocaml-ppx-here)
- (version "0.11.0")
- (source
- (janestreet-origin "ppx_here" version
- "0wxcak3ay4jpigm3pfdcpr65qw4hxfa8whhkryhcd8gy71x056z5"))
- (properties `((upstream-name . "ppx_here"))))))
-
(define-public ocaml-typerep
(package
(name "ocaml-typerep")