summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-12-25 11:46:37 +0100
committerJulien Lepiller <julien@lepiller.eu>2023-12-30 22:12:35 +0100
commitad5a1abec87d861b1d4c45a42fd754a3c5493e9c (patch)
tree6479af052f5d655db55d7f44be68c6d79a3a7f81 /gnu/packages/ocaml.scm
parent34063642500ff05d595a80993f584ba80c8caa12 (diff)
gnu: Remove ocaml4.07-uuidm.
* gnu/packages/ocaml.scm (ocaml4.07-uuidm): Remove variable. (ocaml-uuidm)[properties]: Remove variant. Change-Id: I8ff5a145eb1057f8aff869f865c562134c9afc9d
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm15
1 files changed, 0 insertions, 15 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index a411bb78e0..f59bdb938d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4829,7 +4829,6 @@ tool and piqi-ocaml.")
(propagated-inputs
`(("cmdliner" ,ocaml-cmdliner)
("topkg" ,ocaml-topkg)))
- (properties `((ocaml4.07-variant . ,(delay ocaml4.07-uuidm))))
(home-page "https://erratique.ch/software/uuidm")
(synopsis "Universally unique identifiers for OCaml")
(description "Uuidm is an OCaml module implementing 128 bits universally
@@ -4837,20 +4836,6 @@ unique identifiers (UUIDs) version 3, 5 (named based with MD5, SHA-1 hashing)
and 4 (random based) according to RFC 4122.")
(license license:isc)))
-(define-public ocaml4.07-uuidm
- (package-with-ocaml4.07
- (package
- (inherit ocaml-uuidm)
- (version "0.9.7")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://erratique.ch/software/uuidm/"
- "releases/uuidm-" version ".tbz"))
- (sha256
- (base32
- "1ivxb3hxn9bk62rmixx6px4fvn52s4yr1bpla7rgkcn8981v45r8"))))
- (properties '()))))
-
(define-public ocaml-graph
(package
(name "ocaml-graph")