summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-11-05 19:01:38 +0100
committerDavid Craven <david@craven.ch>2016-12-10 21:47:08 +0100
commit2694d1dc80f174f30b49117192f258e32fe6957b (patch)
tree671c5e0f4d7a5800e6e1b1c13e2b6fc18eb9e3cc /gnu/packages/ocaml.scm
parent60bc622b1d7e70bbc208bf1af356d1157196ae57 (diff)
gnu: coq: Update to 8.5pl2.
* gnu/packages/ocaml.scm (coq): Update to 8.5pl2. [arguments]: Configure script takes single hyphen arguments.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm34
1 files changed, 17 insertions, 17 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f1b4bdbf6f..84bce3dd37 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -329,14 +329,14 @@ written in Objective Caml.")
(define-public coq
(package
(name "coq")
- (version "8.4pl6")
+ (version "8.5pl2")
(source (origin
(method url-fetch)
(uri (string-append "https://coq.inria.fr/distrib/V" version
"/files/" name "-" version ".tar.gz"))
(sha256
(base32
- "1mpbj4yf36kpjg2v2sln12i8dzqn8rag6fd07hslj2lpm4qs4h55"))))
+ "0wyywia0darak2zmc5v0ra9rn0b9whwdfiahralm8v5za499s8w3"))))
(build-system gnu-build-system)
(native-inputs
`(("texlive" ,texlive)
@@ -348,24 +348,24 @@ written in Objective Caml.")
`(#:phases
(modify-phases %standard-phases
(replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (mandir (string-append out "/share/man"))
- (browser "icecat -remote \"OpenURL(%s,new-tab)\""))
- (zero? (system* "./configure"
- "--prefix" out
- "--mandir" mandir
- "--browser" browser)))))
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (mandir (string-append out "/share/man"))
+ (browser "icecat -remote \"OpenURL(%s,new-tab)\""))
+ (zero? (system* "./configure"
+ "-prefix" out
+ "-mandir" mandir
+ "-browser" browser)))))
(replace 'build
- (lambda _
- (zero? (system* "make" "-j" (number->string
- (parallel-job-count))
- "world"))))
+ (lambda _
+ (zero? (system* "make" "-j" (number->string
+ (parallel-job-count))
+ "world"))))
(delete 'check)
(add-after 'install 'check
- (lambda _
- (with-directory-excursion "test-suite"
- (zero? (system* "make"))))))))
+ (lambda _
+ (with-directory-excursion "test-suite"
+ (zero? (system* "make"))))))))
(home-page "https://coq.inria.fr")
(synopsis "Proof assistant for higher-order logic")
(description