summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-06-03 03:21:43 -0400
committerMark H Weaver <mhw@netris.org>2015-06-05 00:58:53 -0400
commitd6b7b5edeccf42747b589cbddfb06c8fec26b18b (patch)
treed02228d0e1574adc478119d359f292fde04ae357 /gnu/packages/ocaml.scm
parent83f4dc36e28fbd0ed9f8661343925d4e380c5370 (diff)
gnu: Add hevea.
* gnu/packages/ocaml.scm (hevea): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index ed9d6509e2..7140c065e4 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -227,3 +227,29 @@ tools for syntax (Stream Parsers and Grammars) and the ability to modify the
concrete syntax of the language (Quotations, Syntax Extensions).")
;; Most files are distributed under bsd-3, but ocaml_stuff/* is under qpl.
(license (list bsd-3 qpl))))
+
+(define-public hevea
+ (package
+ (name "hevea")
+ (version "2.23")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://hevea.inria.fr/distri/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1f9pj48518ixhjxbviv2zx27v4anp92zgg3x704g1s5cki2w33nv"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("ocaml" ,ocaml)))
+ (arguments
+ `(#:tests? #f ; no test suite
+ #:make-flags (list (string-append "PREFIX=" %output))
+ #:phases (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "http://hevea.inria.fr/")
+ (synopsis "LaTeX to HTML translator")
+ (description
+ "HeVeA is a LaTeX to HTML translator that generates modern HTML 5. It is
+written in Objective Caml.")
+ (license qpl)))