summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-10-21 18:11:05 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-10-22 10:21:25 +0200
commit6efc99967800183daa74ba2ebff6185dfcf1b33d (patch)
tree5b39552c0a471cd174520fbdb0b9b2306a597c39 /gnu/packages/ocaml.scm
parentdbfb1a596ae75554fd9bc3f9ff5024789e790091 (diff)
gnu: Update coq-interval to 3.3.0.
* gnu/packages/ocaml.scm (coq-interval): Update to 3.3.0. [inputs]: Add coq-bignums.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index addcdba5a0..b13168c7da 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3781,14 +3781,14 @@ provides BigN, BigZ, BigQ that used to be part of Coq standard library.")
(define-public coq-interval
(package
(name "coq-interval")
- (version "3.2.0")
+ (version "3.3.0")
(source (origin
(method url-fetch)
(uri (string-append "https://gforge.inria.fr/frs/download.php/"
"file/36538/interval-" version ".tar.gz"))
(sha256
(base32
- "16ir7mizl18kwa1ls8fwjih6r87894bvc1r6lh85cd43la7nriq3"))))
+ "08fdcf3hbwqphglvwprvqzgkg0qbimpyhnqsgv3gac4y1ap0f903"))))
(build-system gnu-build-system)
(native-inputs
`(("ocaml" ,ocaml)
@@ -3796,6 +3796,7 @@ provides BigN, BigZ, BigQ that used to be part of Coq standard library.")
("coq" ,coq)))
(propagated-inputs
`(("flocq" ,coq-flocq)
+ ("bignums" ,coq-bignums)
("coquelicot" ,coq-coquelicot)
("mathcomp" ,coq-mathcomp)))
(arguments